summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 77f0aa326d..ad4c30d064 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +32,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.4.0")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -38,7 +40,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "1p9y943kd09pxmsaahbdml2mn2qlwbx23hvbsm1sqbbm8ma9ai8c"))
+ "16dqpbn4saxmmmqd5ya8zdkwvxzz4nim1p4w954zkkdz3cyg86h6"))
(modules '((guix build utils)))
;; Delete bundled ("vendored") free software source code.
(snippet '(begin
@@ -97,7 +99,7 @@
("go-github-com-lucas-clemente-quic-go" ,go-github-com-lucas-clemente-quic-go)
("go-github-com-willf-bloom" ,go-github-com-willf-bloom)
- ;; For tests
+ ;; For tests.
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
(arguments
@@ -1021,29 +1023,27 @@ quoting, commenting, and escaping.")
(license asl2.0))))
(define-public go-github-com-audriusbutkevicius-pfilter
- (let ((commit "c55ef6137fc6f075801eac099cc2687ede0f101d")
- (revision "3"))
- (package
- (name "go-github-com-audriusbutkevicius-pfilter")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AudriusButkevicius/pfilter.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xzhwyd0w21bhvzl5pinn22hp0y6h44rh3s2ppql69rafc6zd3c6"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/AudriusButkevicius/pfilter"))
- (synopsis "Filter packets into multiple virtual connections")
- (description "Pfilter is a Go package for filtering packets into multiple
+ (package
+ (name "go-github-com-audriusbutkevicius-pfilter")
+ (version "0.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AudriusButkevicius/pfilter.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xzhwyd0w21bhvzl5pinn22hp0y6h44rh3s2ppql69rafc6zd3c6"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/AudriusButkevicius/pfilter"))
+ (synopsis "Filter packets into multiple virtual connections")
+ (description "Pfilter is a Go package for filtering packets into multiple
virtual connections from a single physical connection.")
- (home-page "https://github.com/AudriusButkevicius/pfilter")
- (license expat))))
+ (home-page "https://github.com/AudriusButkevicius/pfilter")
+ (license expat)))
(define-public go-github-com-ccding-go-stun
(let ((commit "be486d185f3dfcb2dbf8429332da50a0da7f95a6")