summaryrefslogtreecommitdiff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index aa7d34acc1..4f3fa05aa7 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -236,11 +236,6 @@
(("^add_ceph_test\\(osd-copy-from\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-fast-mark-down\\.sh.*$") "\n"))
#t)))
- (add-before 'configure 'gcc-workaround
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(add-before 'check 'set-check-environment
(lambda _
;; Run tests in parallel.
@@ -288,8 +283,7 @@
(outputs
'("out" "lib"))
(native-inputs
- `(("gcc" ,gcc-7) ;7 or later is required
- ("gperf" ,gperf)
+ `(("gperf" ,gperf)
("pkg-config" ,pkg-config)
("python-cython" ,python-cython)
("python-sphinx" ,python-sphinx)