summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 482eea9178..9e613cd63a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5902,3 +5902,24 @@ Java package that provides routines for various statistical distributions.")
Emacs. It is designed to support editing of scripts and interaction with
various statistical analysis programs such as R, Julia, and JAGS.")
(license license:gpl2+)))
+
+(define-public r-boruta
+ (package
+ (name "r-boruta")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Boruta" version))
+ (sha256
+ (base32
+ "0y2w4wb45kfnzrxcrdsiwgal9fsnlr3wad1sqdc70qv8gp921xbg"))))
+ (properties `((upstream-name . "Boruta")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-ranger" ,r-ranger)))
+ (home-page "https://gitlab.com/mbq/Boruta/")
+ (synopsis
+ "Wrapper Algorithm for All Relevant Feature Selection")
+ (description
+ "An all relevant feature selection wrapper algorithm. It finds relevant features by comparing original attributes' importance with importance achievable at random, estimated using their permuted copies (shadows).")
+ (license license:gpl2+)))