summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm87
1 files changed, 31 insertions, 56 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3f0706665b..5b203d998d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1113,13 +1114,13 @@ using just two functions: melt and dcast (or acast).")
(define-public r-ggplot2
(package
(name "r-ggplot2")
- (version "3.3.3")
+ (version "3.3.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplot2" version))
(sha256
- (base32 "1k136k1sr6dq1xvx6gs6gzji6hbnnwnsb5qivsxrblfv90irxhj5"))))
+ (base32 "1si46bf9p09qzs208hqffwcb40305p361whmwhc1pwrsmx7jjxdh"))))
(build-system r-build-system)
(propagated-inputs
`(("r-digest" ,r-digest)
@@ -1379,13 +1380,13 @@ supported via Andre Simon's highlight package.")
(define-public r-mime
(package
(name "r-mime")
- (version "0.10")
+ (version "0.11")
(source (origin
(method url-fetch)
(uri (cran-uri "mime" version))
(sha256
(base32
- "1xz37fizlx4w3g8kbim7vr5slqd6cmaq5sa0s4q7ayl1bahk6ckq"))))
+ "1h7fz0rqnp970r9q0d95qcxpxm9mb98rqhcdncx0w2qdkyj2fm11"))))
(build-system r-build-system)
(home-page "https://github.com/yihui/mime")
(synopsis "R package to map filenames to MIME types")
@@ -1596,13 +1597,13 @@ R packages that praise their users.")
(define-public r-testthat
(package
(name "r-testthat")
- (version "3.0.2")
+ (version "3.0.4")
(source (origin
(method url-fetch)
(uri (cran-uri "testthat" version))
(sha256
(base32
- "03sbk36vrjhzfap6a9czxw93r7h06rh3mb01inbrhrh5r2pd00qq"))))
+ "0iqizv2gpv9fg766qv8hbkmc6c5i9xcfrmq9k5m2550p28zff2w3"))))
(build-system r-build-system)
(propagated-inputs
`(("r-brio" ,r-brio)
@@ -1706,13 +1707,13 @@ and printing capabilities than traditional data frames.")
(define-public r-dplyr
(package
(name "r-dplyr")
- (version "1.0.6")
+ (version "1.0.7")
(source (origin
(method url-fetch)
(uri (cran-uri "dplyr" version))
(sha256
(base32
- "01zsc9hn2wfvgphn8wcy7j4nvyq2qdl32008alnj0nsr34d3i308"))))
+ "0g8jsxclj9cgm7a2lyazy78sj62rbzw812lsw3fdsbz0pknkmznj"))))
(build-system r-build-system)
(propagated-inputs
`(("r-ellipsis" ,r-ellipsis)
@@ -2024,19 +2025,18 @@ chain.")
(define-public r-ade4
(package
(name "r-ade4")
- (version "1.7-16")
+ (version "1.7-17")
(source
(origin
(method url-fetch)
(uri (cran-uri "ade4" version))
(sha256
(base32
- "142m70im8yd4q01q7z02y3ia0f66yh4ikdznv0ps6c7yyigs5mwv"))))
+ "0s9x29xscgfdk1cdk1hanmkrrgj9vibf5gvwlbx21mhjnf0dzngf"))))
(build-system r-build-system)
(propagated-inputs
`(("r-mass" ,r-mass)
("r-pixmap" ,r-pixmap)
- ("r-progress" ,r-progress)
("r-sp" ,r-sp)))
(home-page "http://pbil.univ-lyon1.fr/ADE-4")
(synopsis "Multivariate data analysis and graphical display")
@@ -2466,13 +2466,13 @@ informative error messages when it's not available.")
(define-public r-devtools
(package
(name "r-devtools")
- (version "2.4.1")
+ (version "2.4.2")
(source (origin
(method url-fetch)
(uri (cran-uri "devtools" version))
(sha256
(base32
- "0jd4ph3z7shqyy8lw34i10qmhqr6z8ihqix96kkayjql315ccah6"))))
+ "01cg2ykg0av6z7bgl41njcxcii8vjj8ipch26xazp4yjai8abw3i"))))
(build-system r-build-system)
(propagated-inputs
`(("r-callr" ,r-callr)
@@ -2736,13 +2736,13 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "2.8")
+ (version "2.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "0qk558n9fxvl0465384mbvkip9jqymjccdvwpxzm54jr0v56gprz"))))
+ (base32 "0s46x819zhf45k8qzpiwz79i5pn4gv99jfadywcjca3wka5szrbc"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
(propagated-inputs
@@ -3286,13 +3286,13 @@ analysis of large sparse or dense matrices.")
(define-public r-glmnet
(package
(name "r-glmnet")
- (version "4.1-1")
+ (version "4.1-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "glmnet" version))
(sha256
- (base32 "0zpfq0m1y5zks5p9r28553ykywwrhrb3ds8m6b7sm6hj4n1c4csd"))))
+ (base32 "1kfd8kfhapx2cxw6qnkbs502c3kya4pd9qmf0mk76cdlq1c2paq6"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)
@@ -3639,13 +3639,13 @@ vignettes.")
(define-public r-mvtnorm
(package
(name "r-mvtnorm")
- (version "1.1-1")
+ (version "1.1-2")
(source (origin
(method url-fetch)
(uri (cran-uri "mvtnorm" version))
(sha256
(base32
- "1pj51mi0g6ip7a2nhzc93yv9289kaayvspjvsbgbgarvx7axlrg9"))))
+ "05wh7mprf2sim2kxh3d72pdcmml6vbikzxavws1dq6mxwlsy2p7j"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -3856,13 +3856,13 @@ features present in other programming languages.")
(define-public r-plotly
(package
(name "r-plotly")
- (version "4.9.3")
+ (version "4.9.4.1")
(source (origin
(method url-fetch)
(uri (cran-uri "plotly" version))
(sha256
(base32
- "0801i2q7sw62x734d58h9p2fwpi1hirqj73gsg18pqkdv4b1lkfl"))))
+ "1q711c0lg0jmzrmcc2fhjy70ms49as7cakdbgbh2ij9s149fa7iq"))))
(build-system r-build-system)
(propagated-inputs
`(("r-base64enc" ,r-base64enc)
@@ -4185,23 +4185,15 @@ Zurich, including many that are related to graphics.")
(define-public r-gtools
(package
(name "r-gtools")
- (version "3.8.2")
+ (version "3.9.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "gtools" version))
(sha256
(base32
- "1pnwy412wvhhvnnx8qg6s9hrgcnsfhnfcpf2560ipipk845acfsh"))))
+ "0lx97yafrms2mjym8rhcq5586z7s1iqgy8qfm4px3xl1yn5qkc83"))))
(build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-deterministic
- (lambda _
- (substitute* "R/checkReverseDependencies.R"
- (("tempdir\\(\\)") "\"/tmp\""))
- #t)))))
(home-page "https://cran.r-project.org/web/packages/gtools")
(synopsis "Various R programming tools")
(description
@@ -5135,13 +5127,13 @@ using modular prediction and response module classes.")
(define-public r-quantreg
(package
(name "r-quantreg")
- (version "5.85")
+ (version "5.86")
(source
(origin
(method url-fetch)
(uri (cran-uri "quantreg" version))
(sha256
- (base32 "1y8sgl16yby1k7g23y6bdnfllwnxj3iik3fqp96iwm5jd8blb7q4"))))
+ (base32 "01fnp6ndh7npxj76xlynndacsgmcfr9kgh2waw0clx3mmwlwilbi"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -5191,14 +5183,14 @@ algorithms.")
(define-public r-lme4
(package
(name "r-lme4")
- (version "1.1-27")
+ (version "1.1-27.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "lme4" version))
(sha256
(base32
- "0px1wppmb6wibac4sismkf82q8870r6h267vxv0ql63qdk3r20zy"))))
+ "1i9f8kl2qj48j75dbn1vmwxz1xlbikdr7v2yq542w6dq74z8gyi5"))))
(build-system r-build-system)
(propagated-inputs
`(("r-boot" ,r-boot)
@@ -5273,13 +5265,13 @@ Companion to Applied Regression, Third Edition, Sage.")
(define-public r-car
(package
(name "r-car")
- (version "3.0-10")
+ (version "3.0-11")
(source
(origin
(method url-fetch)
(uri (cran-uri "car" version))
(sha256
- (base32 "1w95b7xm0bna3qm637pwyv4s7294ffz9dl153naprd79zv91dqqw"))))
+ (base32 "0b2l35656bi75hfvnjhzhlnrnbpjn0vv7nvny8gn65gm0rr94b5k"))))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
@@ -5732,31 +5724,14 @@ to any arbitrary string. In this case, it is up to you to set valid values.")
(define-public python-rpy2
(package
(name "python-rpy2")
- (version "3.3.5")
+ (version "3.4.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rpy2" version))
(sha256
(base32
- "1bs36rds5fq8821l5q85q2b25161rs9ppw5c26x0hjwj487gpcfj"))
- ;; These patches should be removed with the next release.
- (patches
- (list
- (origin
- (method url-fetch)
- (uri "https://github.com/rpy2/rpy2/commit/04c57598f00145d868ea8da31ac1b1e7c49f7570.patch")
- (file-name "python-rpy2-fix-test-failure.patch")
- (sha256
- (base32
- "1lqd3yxjfx1rxrybcmnapy0r6ambg9myrb98q4nlfhpxanwfdbbh")))
- (origin
- (method url-fetch)
- (uri "https://github.com/rpy2/rpy2/commit/685f67d0a6b47ea80e718116a10755019446aef7.patch")
- (file-name "python-rpy2-r-console-test-fix.patch")
- (sha256
- (base32
- "18wpvfaa4c13d44cb4sw88c3c7403xdy5m8h82wfq8fjmcq3cmzn")))))))
+ "1cysswxr5glrdblyl2zsmywcj7xhxn3wmyihxinrz9gm8gmaacax"))))
(build-system python-build-system)
(arguments
'(#:phases