summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm257
1 files changed, 122 insertions, 135 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 82f97c679e..71ff921c62 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -702,14 +702,14 @@ analysis.")
(define-public r-survival
(package
(name "r-survival")
- (version "3.2-3")
+ (version "3.2-7")
(source
(origin
(method url-fetch)
(uri (cran-uri "survival" version))
(sha256
(base32
- "07h76r2y23w889257krlijcw4n4d7ssx92x7i5qb1xyv5gyvl3rx"))))
+ "0ila864g5b9yhjhk3jirgdpi06sksc0axa78890dmkvyv9rwsmjk"))))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)))
@@ -1415,13 +1415,13 @@ emitter (http://pyyaml.org/wiki/LibYAML) for R.")
(define-public r-knitr
(package
(name "r-knitr")
- (version "1.29")
+ (version "1.30")
(source (origin
(method url-fetch)
(uri (cran-uri "knitr" version))
(sha256
(base32
- "00rcwiq8znmk5h4qgrwd0639xyb38iwbjykqjk3disz3kvrcvbn1"))))
+ "0gn9qwc5762a6j0iywfwhalni52g228dcy4bl4di6d52cqsv3ars"))))
(build-system r-build-system)
(propagated-inputs
`(("r-evaluate" ,r-evaluate)
@@ -1965,13 +1965,13 @@ inference for statistical models.")
(define-public r-coda
(package
(name "r-coda")
- (version "0.19-3")
+ (version "0.19-4")
(source (origin
(method url-fetch)
(uri (cran-uri "coda" version))
(sha256
(base32
- "1mn50bshky968gn4nf6vnkaa768fnvm1xmhkms7szwdw9341zpyk"))))
+ "13z5dwfpnyyhpsbpg4xr9g5c1685jhqj90f4x4qkcykr6kykqba2"))))
(build-system r-build-system)
(propagated-inputs
`(("r-lattice" ,r-lattice)))
@@ -2034,14 +2034,14 @@ files in R. It is built on top of the libxml2 C library.")
(define-public r-multitaper
(package
(name "r-multitaper")
- (version "1.0-14")
+ (version "1.0-15")
(source
(origin
(method url-fetch)
(uri (cran-uri "multitaper" version))
(sha256
(base32
- "04wd9bbhyx7697pfy0fpj02v1csr48hkpqj62h9p8a6w84ji4k68"))))
+ "1gm3wr8xqpqiby7q1dr3zxim77v0bvvrqi0hlazf5g3gnkrp2zc3"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -2100,14 +2100,14 @@ limited to R.")
(define-public r-backports
(package
(name "r-backports")
- (version "1.1.9")
+ (version "1.1.10")
(source
(origin
(method url-fetch)
(uri (cran-uri "backports" version))
(sha256
(base32
- "1mz3r6ad484xmx0i89gvmak4wzl4cp59gxdzirrci9znw1axrrvx"))))
+ "1pq16bf40zx441ylmqqqilj3xp39r707h56kwqp5yqklq9yln2z1"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/backports")
(synopsis "Reimplementations of functions introduced since R 3.0.0")
@@ -2322,14 +2322,14 @@ collation, and NAMESPACE files.")
(define-public r-openssl
(package
(name "r-openssl")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "openssl" version))
(sha256
(base32
- "17fkc6pr8w5z3rpadg692a689p1v4j7xl5ak0y64is7c74cxgljx"))))
+ "0sc2skh1nz7jj65p0pq4a6bl8jza6lyi4zvmvwndzxfgivgh281l"))))
(build-system r-build-system)
(inputs
`(("libressl" ,libressl)))
@@ -2426,13 +2426,13 @@ informative error messages when it's not available.")
(define-public r-devtools
(package
(name "r-devtools")
- (version "2.3.1")
+ (version "2.3.2")
(source (origin
(method url-fetch)
(uri (cran-uri "devtools" version))
(sha256
(base32
- "100mgighf6vqsfwv2qw5rlnd5sfvcji9l9jrmx9ii28r9fd2gyas"))))
+ "0vcqs4c5dfjs2ddkclv3z7zzix2zrnrxvzax8hjvjszgp8362275"))))
(build-system r-build-system)
(propagated-inputs
`(("r-callr" ,r-callr)
@@ -2467,13 +2467,13 @@ tools to simplify the devolpment of R packages.")
(define-public r-withr
(package
(name "r-withr")
- (version "2.2.0")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (cran-uri "withr" version))
(sha256
(base32
- "10mmfffjbnb2zq5x0kqhhb4z6va4micc6pjzvlfji34gyhffa8ac"))))
+ "1837vjp35npjrnis1im5xrwj1swpgnms00gkjiz7296l8yckrh1c"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)))
@@ -2511,22 +2511,27 @@ time-of-day values, based on the @code{difftime} class.")
(define-public r-readr
(package
(name "r-readr")
- (version "1.3.1")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (cran-uri "readr" version))
(sha256
(base32
- "1wz496rw0ah433p755n3xac8gh7yzid4xgdjzd1a7wmpkgilvy9k"))))
+ "1fa67h4l9d30ig460xizgzl115i9pm3bk9dvsbrw6awbmf51ic82"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-clipr" ,r-clipr)
+ `(("r-cli" ,r-cli)
+ ("r-clipr" ,r-clipr)
+ ("r-cpp11" ,r-cpp11)
("r-crayon" ,r-crayon)
- ("r-rcpp" ,r-rcpp)
("r-hms" ,r-hms)
+ ("r-lifecycle" ,r-lifecycle)
("r-tibble" ,r-tibble)
("r-r6" ,r-r6)
+ ("r-rlang" ,r-rlang)
("r-bh" ,r-bh)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/hadley/readr")
(synopsis "Read tabular data")
(description
@@ -2690,18 +2695,17 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "2.3")
+ (version "2.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "0vdjq4kcyxkr2m27588kk6yi5g53symjshj4jz4n0j18wz53shji"))))
+ (base32 "1y2156w1abik8df8vl376ilv8s1jg8i0x2w4n4dwrnm3xxgp5kf0"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
(propagated-inputs
- `(("r-base64enc" ,r-base64enc)
- ("r-evaluate" ,r-evaluate)
+ `(("r-evaluate" ,r-evaluate)
("r-htmltools" ,r-htmltools)
("r-jsonlite" ,r-jsonlite)
("r-knitr" ,r-knitr)
@@ -2806,13 +2810,13 @@ a column in data frame.")
(define-public r-rsqlite
(package
(name "r-rsqlite")
- (version "2.2.0")
+ (version "2.2.1")
(source (origin
(method url-fetch)
(uri (cran-uri "RSQLite" version))
(sha256
(base32
- "1m38sj8rwbf3p2lhqabcp7c7djk7s9ng37cz39yxk706v9pi4380"))))
+ "0lynli9144dzb9vhxssba20v7z5h2nirawpvvy8ykv4n3ir7qlsl"))))
(properties `((upstream-name . "RSQLite")))
(build-system r-build-system)
(propagated-inputs
@@ -2824,6 +2828,8 @@ a column in data frame.")
("r-bit64" ,r-bit64)
("r-blob" ,r-blob)
("r-pkgconfig" ,r-pkgconfig)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/rstats-db/RSQLite")
(synopsis "SQLite interface for R")
(description
@@ -3604,13 +3610,13 @@ t-probabilities, quantiles, random deviates and densities.")
(define-public r-matrixstats
(package
(name "r-matrixstats")
- (version "0.56.0")
+ (version "0.57.0")
(source (origin
(method url-fetch)
(uri (cran-uri "matrixStats" version))
(sha256
(base32
- "09qgfv9x32x6ncgf19iy7yjp26fwy6p5wm8spc2xzfc0qhylmqrr"))))
+ "0hzkx7yi9ira476izsgw7r2bhv72ra4z2m9zr1i1f4ivrn3ihs7r"))))
(properties `((upstream-name . "matrixStats")))
(build-system r-build-system)
(native-inputs
@@ -4079,27 +4085,6 @@ framework, with additional code inspection and report generation tools.")
hierarchical clustering dendrograms.")
(license license:gpl2+)))
-(define-public r-preprocesscore
- (package
- (name "r-preprocesscore")
- (version "1.50.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "preprocessCore" version))
- (sha256
- (base32
- "0q1406kswylc8zn5k3wyd34p34pfzbhi1ggkfsh30zcjp6adbwjl"))))
- (properties
- `((upstream-name . "preprocessCore")))
- (build-system r-build-system)
- (home-page "https://github.com/bmbolstad/preprocessCore")
- (synopsis "Collection of pre-processing functions")
- (description
- "This package provides a library of core pre-processing and normalization
-routines.")
- (license license:lgpl2.0+)))
-
(define-public r-fastcluster
(package
(name "r-fastcluster")
@@ -4217,18 +4202,17 @@ including:
(define-public r-gplots
(package
(name "r-gplots")
- (version "3.0.4")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "gplots" version))
(sha256
(base32
- "15ip3v4xiqzbanf8bc5fj90cbwdgixr72aj5jrp34jfdzdx0gxwg"))))
+ "05rislwgaw6v5dmhcwyvc04hi1fgaxrpb61f66kx483px45w6f24"))))
(build-system r-build-system)
(propagated-inputs
`(("r-catools" ,r-catools)
- ("r-gdata" ,r-gdata)
("r-gtools" ,r-gtools)
("r-kernsmooth" ,r-kernsmooth)))
(native-inputs
@@ -4927,14 +4911,14 @@ of the points.")
(define-public r-fpc
(package
(name "r-fpc")
- (version "2.2-7")
+ (version "2.2-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "fpc" version))
(sha256
(base32
- "1xnp3j36hggfg675v39mnr6rgvp7i11pfng7nmyy3k2ldgklz0j9"))))
+ "07a125pji1flmybn6iidcnizwnqyl6chnrckxa5jp4qxxfdqx658"))))
(build-system r-build-system)
(propagated-inputs
`(("r-class" ,r-class)
@@ -5096,13 +5080,13 @@ using modular prediction and response module classes.")
(define-public r-quantreg
(package
(name "r-quantreg")
- (version "5.67")
+ (version "5.73")
(source
(origin
(method url-fetch)
(uri (cran-uri "quantreg" version))
(sha256
- (base32 "09hgch8x6x2k7wm17c0njp7l0r6rrrlcji60afrv19dm9r4596wr"))))
+ (base32 "0mjwwj3c7cfnprlh90ld0f1lll0mrqbx8mpnbfr7bvzg8h6072y4"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -5230,13 +5214,13 @@ Companion to Applied Regression, Third Edition, Sage.")
(define-public r-car
(package
(name "r-car")
- (version "3.0-9")
+ (version "3.0-10")
(source
(origin
(method url-fetch)
(uri (cran-uri "car" version))
(sha256
- (base32 "1clh8c7mj87i4hz27l16w76dpw7k4mlnjbgm9mbrhrfkv0lpb63c"))))
+ (base32 "1w95b7xm0bna3qm637pwyv4s7294ffz9dl153naprd79zv91dqqw"))))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
@@ -5383,14 +5367,14 @@ multivariate case.")
(define-public r-tclust
(package
(name "r-tclust")
- (version "1.4-1")
+ (version "1.4-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "tclust" version))
(sha256
(base32
- "17md6l9v9dl9b72l84df01b52h2xiynbcjm437mv9mzcr09fc2sb"))))
+ "1nb5iky4kc832627jf28lzj19wrvgwg5da6fyl3kyf0npmyx1p4m"))))
(build-system r-build-system)
;; These are all suggested packages, not build dependencies.
(propagated-inputs
@@ -5805,78 +5789,81 @@ Java package that provides routines for various statistical distributions.")
(license license:gpl2+)))
(define-public emacs-ess
- (package
- (name "emacs-ess")
- (version "18.10.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-ess/ESS")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "1yq41l2bicwjrc0b731iic20cpcnz6ppigri1jn621qv2qv22vy3"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Stop ESS from trying to bundle an external julia-mode.el.
- (substitute* "lisp/Makefile"
- (("^ess-julia.elc: julia-mode.elc") "")
- (("^all: julia-mode.el")
- "all:"))
- ;; Include *.el files in install target.
- (substitute* "lisp/Makefile"
- (("\t\\$\\(INSTALL) \\$\\(ELC\\) \\$\\(LISPDIR\\)" elc)
- (string-append "\t$(INSTALL) $(ELS) ess-autoloads.el "
- "$(LISPDIR)\n" elc)))
- ;; Only build docs in info format.
- (substitute* "doc/Makefile"
- (("all : info text")
- "all : info")
- (("install: install-info install-other-docs")
- "install: install-info"))
- ;; Stop install-info from trying to update the info directory.
- (substitute* "doc/Makefile"
- ((".*\\$\\(INFODIR\\)/dir.*") ""))
- ;; Fix roxygen preview test.
- (substitute* "test/ess-r-tests.el"
- (("Add together two numbers.\n")
- "Add together two numbers. ")
- (("##' add\\(10, 1\\)") "add(10, 1)"))
- #t))))
- (build-system gnu-build-system)
- (arguments
- (let ((base-directory "/share/emacs/site-lisp"))
- `(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "ETCDIR=" %output
- ,base-directory "/etc")
- (string-append "LISPDIR=" %output
- ,base-directory))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'more-shebang-patching
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makeconf"
- (("SHELL = /bin/sh")
- (string-append "SHELL = " (which "sh"))))
- #t))
- (replace 'check
- (lambda _
- (invoke "make" "test")))))))
- (inputs
- `(("emacs" ,emacs-minimal)
- ("r-minimal" ,r-minimal)))
- (native-inputs
- `(("perl" ,perl)
- ("r-roxygen2" ,r-roxygen2)
- ("texinfo" ,texinfo)))
- (propagated-inputs
- `(("emacs-julia-mode" ,emacs-julia-mode)))
- (home-page "https://ess.r-project.org/")
- (synopsis "Emacs mode for statistical analysis programs")
- (description "Emacs Speaks Statistics (ESS) is an add-on package for GNU
-Emacs. It is designed to support editing of scripts and interaction with
-various statistical analysis programs such as R, Julia, and JAGS.")
- (license license:gpl2+)))
+ ;; Latest release is old. This is not the latest commit either due to bug
+ ;; reported here: <https://github.com/emacs-ess/ESS/issues/987>.
+ (let ((commit "24da603184ce39246611dd5b8602e769d7ebd5bf")
+ (version "18.10.2")
+ (revision "0"))
+ (package
+ (name "emacs-ess")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-ess/ESS")
+ (commit commit)))
+ (sha256
+ (base32 "0j98lv07nzwzd54d4dgcfz01wy5gj48m0mnirxzh5r45ik2myh1r"))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Stop ESS from trying to bundle an external julia-mode.el.
+ (substitute* "lisp/Makefile"
+ ((" \\$\\(JULIAS)") "")
+ (("\ttest.*julia-mode.*\\.el") ""))
+ ;; Only build docs in info format.
+ (substitute* "doc/Makefile"
+ (("all : info text")
+ "all : info")
+ (("install: install-info install-other-docs")
+ "install: install-info"))
+ ;; Stop install-info from trying to update the info directory.
+ (substitute* "doc/Makefile"
+ ((".*/dir.*") ""))
+ ;; Fix r-help-mode test.
+ (substitute* "test/ess-test-r.el"
+ (("\\(equal ess-help-object \"plot.default\")") "t"))
+ ;; Avoid generating ess-autoloads.el twice.
+ (substitute* "Makefile"
+ (("all: lisp doc etc autoloads")
+ "all: lisp doc etc"))
+ ;; Install to correct directories.
+ (substitute* "Makefile"
+ (("mkdir -p \\$\\(ESSDESTDIR)")
+ "$(MAKE) -C lisp install; $(MAKE) -C doc install")
+ (("\\$\\(INSTALL) -R \\./\\* \\$\\(ESSDESTDIR)/")
+ "$(MAKE) -C etc install"))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ (let ((base-directory "/share/emacs/site-lisp"))
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ (string-append "ETCDIR=" %output
+ ,base-directory "/etc")
+ (string-append "LISPDIR=" %output
+ ,base-directory)
+ (string-append "INFODIR=" %output
+ "/share/info"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda _ (invoke "make" "test")))))))
+ (native-inputs
+ `(("perl" ,perl)
+ ("r-roxygen2" ,r-roxygen2)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("emacs" ,emacs-minimal)
+ ("r-minimal" ,r-minimal)))
+ (propagated-inputs
+ `(("emacs-julia-mode" ,emacs-julia-mode)))
+ (home-page "https://ess.r-project.org/")
+ (synopsis "Emacs mode for statistical analysis programs")
+ (description
+ "Emacs Speaks Statistics (ESS) is an add-on package for GNU Emacs. It
+is designed to support editing of scripts and interaction with various
+statistical analysis programs such as R, Julia, and JAGS.")
+ (license license:gpl3+))))