summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm40
1 files changed, 15 insertions, 25 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7f1460b089..87cb7def34 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;;
@@ -219,9 +220,8 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
#t))
(add-before 'configure 'patch-coreutils-paths
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((coreutils (assoc-ref inputs "coreutils"))
- (uname-bin (string-append coreutils "/bin/uname"))
- (rm-bin (string-append coreutils "/bin/rm")))
+ (let ((uname-bin (search-input-file inputs "/bin/uname"))
+ (rm-bin (search-input-file inputs "/bin/rm")))
(substitute* "src/scripts/R.sh.in"
(("uname") uname-bin))
(substitute* "src/unix/sys-std.c"
@@ -303,9 +303,8 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZ" "UTC+1")
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t))
+ (search-input-directory inputs
+ "share/zoneinfo"))))
(add-after 'build 'make-info
(lambda _ (invoke "make" "info")))
(add-after 'build 'install-info
@@ -345,18 +344,19 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
- ("texlive" ,(texlive-union (list texlive-ae
+ ("texlive" ,(texlive-updmap.cfg (list texlive-ae
texlive-inconsolata
texlive-fonts-ec
- texlive-amsfonts/patched
+ texlive-grfext
+ texlive-amsfonts
texlive-latex-base
texlive-latex-fancyvrb
texlive-latex-graphics
- texlive-latex-hyperref
- texlive-latex-oberdiek
+ texlive-hyperref
+ texlive-oberdiek
texlive-latex-tools
texlive-latex-upquote
- texlive-latex-url
+ texlive-url
texlive-latex-xkeyval)))
("tzdata" ,tzdata-for-tests)
("xz" ,xz)))
@@ -6097,25 +6097,15 @@ to any arbitrary string. In this case, it is up to you to set valid values.")
"1cysswxr5glrdblyl2zsmywcj7xhxn3wmyihxinrz9gm8gmaacax"))))
(build-system python-build-system)
(arguments
- '(#:modules ((ice-9 ftw)
- (srfi srfi-1)
- (srfi srfi-26)
- (guix build utils)
- (guix build python-build-system))
- #:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((cwd (getcwd)))
- (setenv "TZ" "UTC")
- (setenv "PYTHONPATH"
- (string-append cwd "/build/"
- (find (cut string-prefix? "lib" <>)
- (scandir (string-append cwd "/build")))
- ":"
- (getenv "PYTHONPATH"))))
+ (setenv "TZ" "UTC"))
;; test_vector_complex has issues when run in our environment.
- (invoke "pytest" "-v" "rpy2/tests/" "-k" "not test_vector_complex"))))))
+ (invoke "pytest" "-v" "rpy2/tests/"
+ "-k" "not test_vector_complex"))))))
(propagated-inputs
`(("python-cffi" ,python-cffi)
("python-six" ,python-six)