summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 4e217888fd..7452b5f7a1 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -15,7 +15,7 @@
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
@@ -311,11 +311,12 @@ Additionally, various channel-specific options can be negotiated.")
(uri (git-reference
(url home-page)
(commit (string-append "v" version))))
- (file-name (string-append name "-" version ".tar.gz"))
+ (file-name (git-file-name name version))
(sha256
(base32
"1xpxkvgj7wgcl450djkcrmrf957mcy2f36hfs5g6kpla1gax2d1g"))
- (modules '((guix build utils)))))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"
+ "guile-ssh-read-error.patch"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -381,6 +382,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.0-ssh")
+ (source (origin
+ (inherit (package-source guile-ssh))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.0) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))
@@ -391,6 +395,9 @@ libssh library.")
(package
(inherit guile-ssh)
(name "guile2.2-ssh")
+ (source (origin
+ (inherit (package-source guile-ssh))
+ (patches (search-patches "guile-ssh-fix-test-suite.patch"))))
(native-inputs
`(("guile" ,guile-2.2) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))