summaryrefslogtreecommitdiff
path: root/gnu/packages/sqlite.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sqlite.scm')
-rw-r--r--gnu/packages/sqlite.scm50
1 files changed, 6 insertions, 44 deletions
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index a48d724488..c0ea2e670e 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
@@ -48,7 +48,7 @@
(define-public sqlite
(package
(name "sqlite")
- (version "3.31.1")
+ (version "3.35.5")
(source (origin
(method url-fetch)
(uri (let ((numeric-version
@@ -60,19 +60,14 @@
(map (cut string-pad <> 2 #\0)
other-digits))
6 #\0))))))
- (string-append "https://sqlite.org/2020/sqlite-autoconf-"
+ (string-append "https://sqlite.org/2021/sqlite-autoconf-"
numeric-version ".tar.gz")))
+ (patches (search-patches "sqlite-hurd.patch"))
(sha256
(base32
- "1bj936svd8i5g25xd1bj52hj4zca01fgl3sqkj86z9q5pkz4wa32"))))
- (replacement sqlite/fixed)
+ "1c3d5q9zc93pfpbl7p5212pqfvls2ciy34ksxlbfbhqrqfjp4azm"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
- (native-inputs (if (hurd-target?)
- ;; TODO move into origin on the next rebuild cycle.
- `(("hurd-locking-mode.patch"
- ,@(search-patches "sqlite-hurd.patch")))
- '()))
(outputs '("out" "static"))
(arguments
`(#:configure-flags
@@ -80,25 +75,13 @@
;; -DSQLITE_ENABLE_UNLOCK_NOTIFY and -DSQLITE_ENABLE_DBSTAT_VTAB
;; to CFLAGS. GNU Icecat will refuse to use the system SQLite
;; unless these options are enabled.
- (list (string-append "CFLAGS=-O2 -DSQLITE_SECURE_DELETE "
+ (list (string-append "CFLAGS=-O2 -g -DSQLITE_SECURE_DELETE "
"-DSQLITE_ENABLE_FTS3 "
"-DSQLITE_ENABLE_UNLOCK_NOTIFY "
"-DSQLITE_ENABLE_DBSTAT_VTAB "
;; Column metadata is required by GNU Jami and Qt, et.al.
"-DSQLITE_ENABLE_COLUMN_METADATA"))
#:phases (modify-phases %standard-phases
- ;; TODO: remove in the next rebuild cycle
- ,@(if (hurd-target?)
- `((add-after 'unpack 'patch-sqlite/hurd
- (lambda* (#:key inputs native-inputs
- #:allow-other-keys)
- (let ((patch (assoc-ref
- (if ,(%current-target-system)
- native-inputs
- inputs)
- "hurd-locking-mode.patch")))
- (invoke "patch" "-p1" "--force" "-i" patch)))))
- '())
(add-after 'install 'move-static-library
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -123,27 +106,6 @@ widely deployed SQL database engine in the world. The source code for SQLite
is in the public domain.")
(license license:public-domain)))
-(define-public sqlite/fixed
- (package
- (inherit sqlite)
- (version "3.32.3")
- (source (origin
- (method url-fetch)
- (uri (let ((numeric-version
- (match (string-split version #\.)
- ((first-digit other-digits ...)
- (string-append first-digit
- (string-pad-right
- (string-concatenate
- (map (cut string-pad <> 2 #\0)
- other-digits))
- 6 #\0))))))
- (string-append "https://sqlite.org/2020/sqlite-autoconf-"
- numeric-version ".tar.gz")))
- (sha256
- (base32
- "0rlbaq177gcgk5dswd3akbhv2nvvzljrbhgy18hklbhw7h90f5d3"))))))
-
;; Column metadata support was added to the regular 'sqlite' package with
;; commit fad5b1a6d8d9c36bea5785ae4fbc1beb37e644d7.
(define-public sqlite-with-column-metadata