summaryrefslogtreecommitdiff
path: root/gnu/packages/sqlite.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sqlite.scm')
-rw-r--r--gnu/packages/sqlite.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index 8468131ddf..eeb77749d8 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
(define-module (gnu packages sqlite)
#:use-module (gnu packages)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages readline)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -65,6 +67,11 @@
"1bj936svd8i5g25xd1bj52hj4zca01fgl3sqkj86z9q5pkz4wa32"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
+ (native-inputs (if (hurd-target?)
+ ;; TODO move into origin on the next rebuild cycle.
+ `(("hurd-locking-mode.patch"
+ ,@(search-patches "sqlite-hurd.patch")))
+ '()))
(outputs '("out" "static"))
(arguments
`(#:configure-flags
@@ -79,6 +86,18 @@
;; Column metadata is required by GNU Jami and Qt, et.al.
"-DSQLITE_ENABLE_COLUMN_METADATA"))
#:phases (modify-phases %standard-phases
+ ;; TODO: remove in the next rebuild cycle
+ ,@(if (hurd-target?)
+ `((add-after 'unpack 'patch-sqlite/hurd
+ (lambda* (#:key inputs native-inputs
+ #:allow-other-keys)
+ (let ((patch (assoc-ref
+ (if ,(%current-target-system)
+ native-inputs
+ inputs)
+ "hurd-locking-mode.patch")))
+ (invoke "patch" "-p1" "--force" "-i" patch)))))
+ '())
(add-after 'install 'move-static-library
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))