summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 9c88b63108..94976ab130 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -252,6 +252,14 @@ which allows users to view a desktop computing environment.")
'("--enable-lz4"
"--enable-automated-tests")
+ #:phases
+ (modify-phases %standard-phases
+ ;; XXX: Otherwise the server listen tests fails with
+ ;; Failed to create /homeless-shelter/.config/glib-2.0/settings
+ (add-before 'check 'set-XDG_CONFIG_HOME
+ (lambda _
+ (setenv "XDG_CONFIG_HOME" "/tmp"))))
+
;; Several tests appear to be opening the same sockets concurrently.
#:parallel-tests? #f))
(synopsis "Server implementation of the SPICE protocol")
@@ -340,17 +348,6 @@ resolution scaling on graphical console window resize.")
(base32
"1rrjlclm6ad63gah1fa4yfwrz4z6vgq2yrybbvzvvdbxrgl4vgzv"))))
(build-system meson-build-system)
- (arguments
- '(#:tests? #f ; TODO Tests require gnutls built with
- ; p11-kit
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "tests/setup-softhsm2.sh"
- (("\\/usr\\/lib64\\/pkcs11\\/libsofthsm2\\.so")
- (string-append (assoc-ref inputs "softhsm")
- "/lib/softhsm/libsofthsm2.so"))))))))
(propagated-inputs
`(("glib" ,glib) ; Requires: in the pkg-config file
("nss" ,nss) ; Requires.private: in the pkg-config
@@ -359,7 +356,6 @@ resolution scaling on graphical console window resize.")
`(("openssl" ,openssl)
("nss" ,nss "bin")
("opensc" ,opensc)
- ("softhsm" ,softhsm)
("gnutls" ,gnutls)
("pkg-config" ,pkg-config)
("which" ,which)))