summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index e708d726bb..94e6aa8438 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -211,6 +211,10 @@ which allows users to view a desktop computing environment.")
`(#:configure-flags
'("--enable-lz4"
"--enable-automated-tests")
+
+ ;; Several tests appear to be opening the same sockets concurrently.
+ #:parallel-tests? #f
+
#:phases (modify-phases %standard-phases
(add-before 'check 'use-empty-ssl-cert-file
(lambda _ (setenv "SSL_CERT_FILE" "/dev/null") #t)))))
@@ -250,7 +254,7 @@ Internet and from a wide variety of machine architectures.")
(add-after 'unpack 'patch-spice-vdagent.desktop
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "data/spice-vdagent.desktop"
- (("Exec=/usr/bin/spice-vdagent\n")
+ (("Exec=/usr/bin/spice-vdagent")
(string-append "Exec=" (assoc-ref outputs "out")
"/bin/spice-vdagent")))
#t)))))