summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 7fce241aca..76670463d7 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -252,6 +252,14 @@ which allows users to view a desktop computing environment.")
'("--enable-lz4"
"--enable-automated-tests")
+ #:phases
+ (modify-phases %standard-phases
+ ;; XXX: Otherwise the server listen tests fails with
+ ;; Failed to create /homeless-shelter/.config/glib-2.0/settings
+ (add-before 'check 'set-XDG_CONFIG_HOME
+ (lambda _
+ (setenv "XDG_CONFIG_HOME" "/tmp"))))
+
;; Several tests appear to be opening the same sockets concurrently.
#:parallel-tests? #f))
(synopsis "Server implementation of the SPICE protocol")
@@ -342,9 +350,7 @@ resolution scaling on graphical console window resize.")
"0azj3rqr2smg0lai24xrn3zr628xmjfrzcggay877zrr64ybj1c0"))))
(build-system meson-build-system)
(arguments
- '(#:tests? #f ; TODO Tests require gnutls built with
- ; p11-kit
- #:phases
+ '(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-tests
(lambda* (#:key inputs #:allow-other-keys)