summaryrefslogtreecommitdiff
path: root/gnu/packages/smalltalk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/smalltalk.scm')
-rw-r--r--gnu/packages/smalltalk.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index 742a9b89c4..ea1798ac13 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -46,15 +46,16 @@
(define-public smalltalk
(package
(name "smalltalk")
- (version "3.2.5")
+ (version "3.2.91")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://gnu/smalltalk/smalltalk-"
+ ;; XXX: Revert to mirror://gnu with the next release of Smalltalk.
+ (uri (string-append "https://alpha.gnu.org/gnu/smalltalk/smalltalk-"
version ".tar.xz"))
(sha256
(base32
- "1k2ssrapfzhngc7bg1zrnd9n2vyxp9c9m70byvsma6wapbvib6l1"))
+ "1zb2h5cbz1cwybqjl24lflw359lwj7sjvvhwb4x6miypzhwq4qh0"))
;; XXX: To be removed with the next release of Smalltalk.
(patches (search-patches "smalltalk-multiplication-overflow.patch"))))
(build-system gnu-build-system)