summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5527e8ab79..8b41c8d613 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -292,20 +292,18 @@ history mechanism, job control and a C-like syntax.")
(define-public zsh
(package
(name "zsh")
- (version "5.4.2")
+ (version "5.5.1")
(source (origin
(method url-fetch)
(uri (list (string-append
"http://www.zsh.org/pub/zsh-" version
- ".tar.gz")
+ ".tar.xz")
(string-append
"http://www.zsh.org/pub/old/zsh-" version
- ".tar.gz")))
- (patches (search-patches "zsh-CVE-2018-7548.patch"
- "zsh-CVE-2018-7549.patch"))
+ ".tar.xz")))
(sha256
(base32
- "1jdcfinzmki2w963msvsanv29vqqfmdfm4rncwpw0r3zqnrcsywm"))))
+ "105aqkdfsdxc4531anrj2zis2ywz6icagjam9lsc235yzh48ihz1"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
#:phases