summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 052eb0ddb9..a948547f72 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -103,9 +103,10 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
"0nhc3yc5lnnan7zmxqqxm07rdpwjww5ijy45ll2njdc6fnfb2az4"))
(modules '((guix build utils)))
;; Don't try to install /etc/fish/config.fish.
- (snippet
- '(substitute* "Makefile.in"
- ((".*INSTALL.*sysconfdir.*fish.*") "")))))
+ (snippet '(begin
+ (substitute* "Makefile.in"
+ ((".*INSTALL.*sysconfdir.*fish.*") ""))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)))
@@ -264,7 +265,7 @@ written by Paul Haahr and Byron Rakitzis.")
(substitute* "tests/syntax.at"
(("; other_script.csh") "; /bin/sh other_script.csh"))
;; Now, let's generate the test suite and patch it
- (system* "make" "tests/testsuite")
+ (invoke "make" "tests/testsuite")
;; This file is ISO-8859-1 encoded.
(with-fluids ((%default-port-encoding #f))