summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 562748da4a..109baacc30 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -441,8 +441,16 @@ history mechanism, job control and a C-like syntax.")
(base32
"09yyaadq738zlrnlh1hd3ycj1mv3q5hh4xl1ank70mjnqm6bbi6w"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre"
- "--enable-maildir-support")
+ (arguments `(#:configure-flags
+ `("--with-tcsetpgrp"
+ "--enable-pcre"
+ "--enable-maildir-support"
+ ;; share/zsh/site-functions isn't populated
+ "--disable-site-fndir"
+ ,(string-append
+ "--enable-additional-fpath="
+ "/usr/local/share/zsh/site-functions," ; for foreign OS
+ "/run/current-system/profile/share/zsh/site-functions"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-sh
@@ -795,14 +803,14 @@ Shell (pdksh).")
(package
(name "oil")
;; https://www.oilshell.org/blog/2020/04/release-0.8.pre4.html#comment-on-version-numbering
- (version "0.8.pre5")
+ (version "0.8.pre6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "02llxx10izxpv1y32qn8k6r0y7al01rzxjirc8h6x8nd9kiaqknl"))))
+ (base32 "11nfwn5b1w74hv78065jg2zm45mqzi59381b0f649j7n3g7yp3iq"))))
(build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f ; strip breaks the binary
@@ -819,7 +827,7 @@ Shell (pdksh).")
(replace 'check
;; The tests are not distributed in the tarballs but upstream
;; recommends running this smoke test.
- ;; https://github.com/oilshell/oil/blob/release/0.8.pre5/INSTALL.txt#L38-L48
+ ;; https://github.com/oilshell/oil/blob/release/0.8.pre6/INSTALL.txt#L38-L48
(lambda _
(let* ((oil "_bin/oil.ovm"))
(invoke/quiet oil "osh" "-c" "echo hi")