summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm107
1 files changed, 51 insertions, 56 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 33290862bf..3de26f7201 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
@@ -97,7 +98,7 @@
#t))))
(build-system gnu-build-system)
(inputs
- `(("libedit" ,libedit)))
+ (list libedit))
(arguments
'(#:configure-flags '("--with-libedit")))
(home-page "http://gondor.apana.org.au/~herbert/dash")
@@ -129,14 +130,11 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
(delete-file-recursively "pcre2")))))
(build-system cmake-build-system)
(inputs
- `(("fish-foreign-env" ,fish-foreign-env)
- ("ncurses" ,ncurses)
- ("pcre2" ,pcre2) ; don't use the bundled PCRE2
- ("python" ,python))) ; for fish_config and manpage completions
+ (list fish-foreign-env ncurses pcre2 ; don't use the bundled PCRE2
+ python)) ; for fish_config and manpage completions
(native-inputs
- `(("doxygen" ,doxygen)
- ("groff" ,groff) ; for 'fish --help'
- ("procps" ,procps))) ; for the test suite
+ (list doxygen groff ; for 'fish --help'
+ procps)) ; for the test suite
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -296,16 +294,15 @@ and syntax highlighting.")
,(string-append func-path "/fenv.apply.fish")
,(string-append func-path "/fenv.main.fish"))
(("bash")
- (string-append (assoc-ref %build-inputs "bash") "/bin/bash"))
+ (search-input-file %build-inputs "/bin/bash"))
(("sed")
- (string-append (assoc-ref %build-inputs "sed") "/bin/sed"))
+ (search-input-file %build-inputs "/bin/sed"))
((" tr ")
- (string-append " " (assoc-ref %build-inputs "coreutils")
- "/bin/tr ")))))))
+ (string-append " "
+ (search-input-file %build-inputs "/bin/tr")
+ " ")))))))
(inputs
- `(("bash" ,bash)
- ("coreutils" ,coreutils)
- ("sed" ,sed)))
+ (list bash coreutils sed))
(home-page "https://github.com/oh-my-fish/plugin-foreign-env")
(synopsis "Foreign environment interface for fish shell")
(description "@code{fish-foreign-env} wraps bash script execution in a way
@@ -340,12 +337,8 @@ into fish.")
(("/bin/rm") (which "rm"))
(("/bin\\)") (string-append (dirname (which "rm")) ")")))
#t)))))
- (inputs `(("readline" ,readline)
- ("perl" ,perl)))
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (inputs (list readline perl))
+ (native-inputs (list autoconf automake libtool pkg-config))
(synopsis "Alternative implementation of the rc shell by Byron Rakitzis")
(description
"This is a reimplementation by Byron Rakitzis of the Plan 9 shell. It
@@ -376,9 +369,9 @@ has a small feature set similar to a traditional Bourne shell.")
(lambda _
(chdir ".."))))))
(inputs
- `(("readline" ,readline)))
+ (list readline))
(native-inputs
- `(("bison" ,bison)))
+ (list bison))
(synopsis "Extensible shell with higher-order functions")
(description
"Es is an extensible shell. The language was derived from the Plan 9
@@ -392,7 +385,7 @@ written by Paul Haahr and Byron Rakitzis.")
(define-public tcsh
(package
(name "tcsh")
- (version "6.22.02")
+ (version "6.22.03")
(source (origin
(method url-fetch)
;; Old tarballs are moved to old/.
@@ -402,15 +395,14 @@ written by Paul Haahr and Byron Rakitzis.")
"old/tcsh-" version ".tar.gz")))
(sha256
(base32
- "0nw8prz1n0lmr82wnpyhrzmki630afn7p9cfgr3vl00vr9c72a7d"))
+ "1dv24bsp6faayinvwds092ylk9sb6894rl9ddm87y31a7mjzsb5y"))
(patches (search-patches "tcsh-fix-autotest.patch"))
(patch-flags '("-p0"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("perl" ,perl)))
+ (list autoconf perl))
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -427,6 +419,16 @@ written by Paul Haahr and Byron Rakitzis.")
;; Take care of pwd
(substitute* '("tests/commands.at" "tests/variables.at")
(("/bin/pwd") (which "pwd")))
+ (substitute* "Makefile"
+ ;; Likewise for /usr/bin/env.
+ (("/usr/bin/env") "env")
+ ;; Don't reset the environment (PATH, etc).
+ (("\\$\\(ENVCMD\\) -") "$(ENVCMD)"))
+ ;; This test does not expect the home directory from
+ ;; /etc/passwd to be '/'.
+ (substitute* "tests/subst.at"
+ (("\\$\\(id -un\\)/foo")
+ "$(id -un)//foo"))
;; The .at files create shell scripts without shebangs. Erk.
(substitute* "tests/commands.at"
(("./output.sh") "/bin/sh output.sh"))
@@ -514,10 +516,8 @@ history mechanism, job control and a C-like syntax.")
(("command -p") "command ")
(("'command' -p") "'command' "))
#t)))))
- (native-inputs `(("autoconf" ,autoconf)))
- (inputs `(("ncurses" ,ncurses)
- ("pcre" ,pcre)
- ("perl" ,perl)))
+ (native-inputs (list autoconf))
+ (inputs (list ncurses pcre perl))
(synopsis "Powerful shell for interactive use and scripting")
(description "The Z shell (zsh) is a Unix shell that can be used
as an interactive login shell and as a powerful command interpreter
@@ -565,7 +565,7 @@ ksh, and tcsh.")
;; information.
#:tests? #f))
(inputs
- `(("python-ply" ,python-ply)))
+ (list python-ply))
(home-page "https://xon.sh/")
(synopsis "Python-ish shell")
(description
@@ -607,11 +607,9 @@ use of experts and novices alike.")
(symlink rxpath "rx"))
#t)))))
(inputs
- `(("scheme48" ,scheme48)
- ("scheme48-rx" ,scheme48-rx)))
+ (list scheme48 scheme48-rx))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
+ (list autoconf automake))
(home-page "https://github.com/scheme/scsh")
(synopsis "Unix shell embedded in Scheme")
(description
@@ -687,7 +685,7 @@ Its features include:
"0qiny71ww5nhzy4mnc8652hn0mlxyb67h333gbdxp4j4qxsi13q4"))))
(build-system gnu-build-system)
(inputs
- `(("linenoise" ,linenoise)))
+ (list linenoise))
(arguments
`(#:tests? #f
#:make-flags (list "CC=gcc"
@@ -774,9 +772,9 @@ The OpenBSD Korn Shell is a cleaned up and enhanced ksh.")
(base32 "0x33plxqhh5202hgqidgccz5hpg8d2q71ylgnm437g60mfi9z0px"))))
(build-system meson-build-system)
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(arguments
`(#:tests? #f)) ; no tests included
(home-page "https://github.com/dimkr/loksh")
@@ -860,7 +858,7 @@ Shell (pdksh).")
(invoke/quiet oil "osh" "-c" "echo hi")
(invoke/quiet oil "osh" "-n" "configure"))))))))
(inputs
- `(("readline" ,readline)))
+ (list readline))
(home-page "https://www.oilshell.org")
(synopsis "Programming language and Bash-compatible Unix shell")
(description "Oil is a programming language with automatic translation for
@@ -890,9 +888,9 @@ scripts.")
#t))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("guile" ,guile-3.0)))
+ (list guile-3.0))
(arguments
'(#:make-flags '("XFAIL_TESTS=tests/redirects.org")))
(home-page "https://savannah.nongnu.org/projects/gash/")
@@ -925,10 +923,9 @@ as part of the Guix bootstrap process.")
#t))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("guile" ,guile-3.0)
- ("gash" ,gash)))
+ (list guile-3.0 gash))
(home-page "https://savannah.nongnu.org/projects/gash/")
(synopsis "Core POSIX utilities written in Guile Scheme")
(description "Gash-Utils provides Scheme implementations of many
@@ -954,8 +951,7 @@ files and text.")
(base32 "1db521jrs0yxwmvkkl8wssa8qyi0m62n69l7xxl2gpyz1v8nvw76"))))
(build-system cargo-build-system)
(arguments
- `(#:rust ,rust-1.52
- #:tests? #false ;missing files
+ `(#:tests? #false ;missing files
#:features '("extra")
#:cargo-inputs
(("rust-ctrlc" ,rust-ctrlc-3)
@@ -1014,15 +1010,14 @@ files and text.")
("rust-rstest" ,rust-rstest-0.10)
("rust-serial-test" ,rust-serial-test-0.5))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list pkg-config python))
(inputs
- `(("curl" ,curl)
- ("libgit2" ,libgit2)
- ("libx11" ,libx11)
- ("libxcb" ,libxcb)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list curl
+ libgit2
+ libx11
+ libxcb
+ openssl
+ zlib))
(home-page "https://www.nushell.sh")
(synopsis "Shell that understands the structure of the data")
(description