summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0e27b1e5d5..2c3979ca18 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -72,6 +72,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils))
@@ -827,36 +828,35 @@ Shell (pdksh).")
(define-public oil
(package
(name "oil")
- (version "0.9.5")
+ (version "0.9.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.oilshell.org/download/oil-"
version ".tar.gz"))
(sha256
- (base32 "0q29k500is2iif77dkpr7zncjg6ghzmmxs7c9pr2hjz8vvykv58x"))))
+ (base32 "01lmj4diqpla1gwwb1gh1shf4y74qhanpkzcsnb28458rxm1sq32"))))
(build-system gnu-build-system)
(arguments
- `(#:strip-binaries? #f ; strip breaks the binary
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "CC" ,(cc-for-target))
- (substitute* "configure"
- ((" cc ") " $CC "))
- (invoke "./configure" (string-append "--prefix=" out)
- "--with-readline"))))
- (replace 'check
- ;; The tests are not distributed in the tarballs but upstream
- ;; recommends running this smoke test.
- ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (let* ((oil "_bin/oil.ovm"))
- (invoke/quiet oil "osh" "-c" "echo hi")
- (invoke/quiet oil "osh" "-n" "configure"))))))))
+ (list #:strip-binaries? #f ; strip breaks the binary
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (setenv "CC" #$(cc-for-target))
+ (substitute* "configure"
+ ((" cc ") " $CC "))
+ (invoke "./configure" (string-append "--prefix=" #$output)
+ "--with-readline")))
+ (replace 'check
+ ;; The tests are not distributed in the tarballs but upstream
+ ;; recommends running this smoke test.
+ ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (let* ((oil "_bin/oil.ovm"))
+ (invoke/quiet oil "osh" "-c" "echo hi")
+ (invoke/quiet oil "osh" "-n" "configure"))))))))
(inputs
(list readline))
(home-page "https://www.oilshell.org")