summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index eb89c2a5ca..4619b83921 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -121,9 +121,14 @@ readers and is needed to communicate with such devices through the
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; The github tarball doesn't contain a configure script.
- (add-before 'configure 'autoreconf
- (lambda _ (zero? (system* "autoreconf" "-i")))))))
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ ;; configure.ac relies on ‘git --describe’ to get the version.
+ ;; Patch it to just return the real version number directly.
+ (substitute* "scripts/build-aux/genver.sh"
+ (("/bin/sh") (which "sh"))
+ (("\\$GITDESC") ,version))
+ (invoke "sh" "./bootstrap.sh"))))))
(synopsis "Belgian eID Middleware")
(description "The Belgian eID Middleware is required to authenticate with
online services using the Belgian electronic identity card.")