summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index accab82419..dfa43bb2bf 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -362,7 +362,7 @@ and other operations. It includes a library and a command-line tool.")
(define-public yubikey-personalization
(package
(name "yubikey-personalization")
- (version "1.19.3")
+ (version "1.20.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -370,7 +370,14 @@ and other operations. It includes a library and a command-line tool.")
"/Releases/ykpers-" version ".tar.gz"))
(sha256
(base32
- "0jhvnavjrpwzmmjcw486df5s48j53njqgyz36yz3dskbaz3kwlfr"))))
+ "14wvlwqnwj0gllkpvfqiy8ns938bwvjsz8x1hmymmx32m074vj0f"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix build with GCC 10, remove for versions > 1.20.0.
+ '(begin
+ (substitute* "ykpers-args.h"
+ (("^const char")
+ "extern const char"))))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-udevrulesdir="