summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 2ab8a85702..8f9f2ed2a4 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -103,7 +103,7 @@ readers and is needed to communicate with such devices through the
(define-public eid-mw
(package
(name "eid-mw")
- (version "4.4.23")
+ (version "4.4.27")
(source
(origin
(method git-fetch)
@@ -112,7 +112,7 @@ readers and is needed to communicate with such devices through the
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0kf147zxsp5ilghr46hjxa2nsikhv8198n04q81qzn9zln69av04"))))
+ (base32 "17lw8iwp7h5cs3db80sysr84ffi333cf2vrhncs9l6hy6glfl2v1"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -139,7 +139,7 @@ readers and is needed to communicate with such devices through the
;; Patch it to just return the real version number directly.
(substitute* "scripts/build-aux/genver.sh"
(("/bin/sh") (which "sh"))
- (("^(GITDESC=).*" match) (string-append match ,version "\n")))
+ (("^(GITDESC=).*" _ match) (string-append match ,version "\n")))
(invoke "sh" "./bootstrap.sh"))))))
(synopsis "Belgian eID Middleware")
(description "The Belgian eID Middleware is required to authenticate with
@@ -357,7 +357,7 @@ and other operations. It includes a library and a command-line tool.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libusb" ,libusb)
;; The library "libyubikey" is also known as "yubico-c".
("libyubikey" ,libyubikey)))
@@ -457,7 +457,7 @@ PCSC API Python wrapper module.")
"/xml/dtd/docbook/docbookx.dtd")))
#t)))))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("hidapi" ,hidapi)))
(native-inputs
`(("help2man" ,help2man)
@@ -497,7 +497,7 @@ operations.")
(list "--enable-gtk-doc"
"--enable-tests")))
(inputs
- `(("json-c" ,json-c)
+ `(("json-c" ,json-c-0.13)
("libressl" ,libressl)))
(native-inputs
`(("autoconf" ,autoconf)