summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 25b0bdba2b..105296cd0f 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -115,16 +115,15 @@ joystick, and graphics hardware.")
(define-public sdl2
(package (inherit sdl)
(name "sdl2")
- (version "2.0.10")
+ (version "2.0.12")
(source (origin
(method url-fetch)
(uri
(string-append "https://libsdl.org/release/SDL2-"
version ".tar.gz"))
- (patches (search-patches "sdl2-mesa-compat.patch"))
(sha256
(base32
- "0mqxp6w5jhbq6y1j690g9r3gpzwjxh4czaglw8x05l7hl49nqrdl"))))
+ "0qy8wbqvfkb5ps8kxgaaf2zzpkjqbsw712hlp74znbn0jpv6i4il"))))
(arguments
(substitute-keyword-arguments (package-arguments sdl)
((#:configure-flags flags)
@@ -132,20 +131,26 @@ joystick, and graphics hardware.")
"--disable-kmsdrm-shared")
,flags))
((#:make-flags flags ''())
- ;; Add the Fcitx header files to GCCs "system header" search path
- ;; in order to suppress compiler warnings induced by those:
- ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
- ;; mixed declarations and code [-Werror=declaration-after-statement]
- `(append (list (string-append "C_INCLUDE_PATH="
- (assoc-ref %build-inputs "fcitx")
- "/include"))
- ,flags))))
+ `(cons*
+ ;; Add the Fcitx header files to GCCs "system header" search path
+ ;; in order to suppress compiler warnings induced by those:
+ ;; .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
+ ;; mixed declarations and code [-Werror=declaration-after-statement]
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "fcitx") "/include")
+ ;; SDL dlopens libudev, so make sure it is in rpath. This overrides
+ ;; the LDFLAG set in sdl’s configure-flags, which isn’t necessary
+ ;; as sdl2 includes Mesa by default.
+ (string-append "LDFLAGS=-Wl,-rpath,"
+ (assoc-ref %build-inputs "eudev") "/lib")
+ ,flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems
;; experience a bug where input events are doubled.
;;
;; For more information, see: https://dev.solus-project.com/T1721
(append `(("dbus" ,dbus)
+ ("eudev" ,eudev) ; for discovering input devices
("fcitx" ,fcitx) ; helps with CJK input
("glib" ,glib)
("ibus" ,ibus)
@@ -340,14 +345,12 @@ SDL.")
"SDL_Pango-" version ".tar.gz"))
(sha256
(base32 "197baw1dsg0p4pljs5k0fshbyki00r4l49m1drlpqw6ggawx6xbz"))
- (patches
- (search-patches
- "sdl-pango-api_additions.patch"
- "sdl-pango-blit_overflow.patch"
- "sdl-pango-fillrect_crash.patch"
- "sdl-pango-fix-explicit-SDLPango_CopyFTBitmapTo.patch"
- "sdl-pango-matrix_declarations.patch"
- "sdl-pango-sans-serif.patch"))))
+ (patches (search-patches "sdl-pango-api_additions.patch"
+ "sdl-pango-blit_overflow.patch"
+ "sdl-pango-fillrect_crash.patch"
+ "sdl-pango-header-guard.patch"
+ "sdl-pango-matrix_declarations.patch"
+ "sdl-pango-sans-serif.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--disable-static")