summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm44
1 files changed, 25 insertions, 19 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4178a45a89..926169ce18 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages tls)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages libedit)
#:use-module (ice-9 match))
(define (mit-scheme-source-directory system version)
@@ -104,6 +105,10 @@
(find-files "src/compiler" "^make\\.")))
(chdir "src")
#t))
+ ;; FIXME: the texlive-union insists on regenerating fonts. It stores
+ ;; them in HOME, so it needs to be writeable.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t))
(replace 'build
(lambda* (#:key system outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -150,7 +155,7 @@
(delete-file-recursively old-doc-dir)
#t))))))
(native-inputs
- `(("texlive" ,texlive)
+ `(("texlive" ,(texlive-union (list texlive-tex-texinfo)))
("texinfo" ,texinfo)
("m4" ,m4)))
(inputs
@@ -407,21 +412,19 @@ implementation techniques and as an expository tool.")
(define-public racket
(package
(name "racket")
- (version "6.12")
+ (version "7.0")
(source (origin
- (method url-fetch)
- (uri (list (string-append "http://mirror.racket-lang.org/installers/"
- version "/racket-" version "-src.tgz")
- (string-append
- "http://mirror.informatik.uni-tuebingen.de/mirror/racket/"
- version "/racket-" version "-src.tgz")))
- (sha256
- (base32
- "0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))
- (patches (search-patches
- ;; See: https://github.com/racket/racket/issues/1962
- ;; This can be removed in whatever Racket release comes after 6.12
- "racket-fix-xform-issue.patch"))))
+ (method url-fetch)
+ (uri (list (string-append "http://mirror.racket-lang.org/installers/"
+ version "/racket-" version "-src.tgz")
+ (string-append
+ "http://mirror.informatik.uni-tuebingen.de/mirror/racket/"
+ version "/racket-" version "-src.tgz")))
+ (sha256
+ (base32
+ "1glv5amsp9xp480d4yr63hhm9kkyav06yl3a6p489nkr4cln0j9a"))
+ (patches (search-patches
+ "racket-store-checksum-override.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -484,7 +487,9 @@ implementation techniques and as an expository tool.")
("share/pkgs/gui-lib/mred/private/wx/gtk/gl-context.rkt"
("libGL"))
("share/pkgs/sgl/gl.rkt"
- ("libGL" "libGLU")))))
+ ("libGL" "libGLU"))
+ ("share/pkgs/readline-lib/readline/rktrl.rkt"
+ ("libedit")))))
(chdir "src")
#t))
(add-after 'unpack 'patch-/bin/sh
@@ -492,7 +497,7 @@ implementation techniques and as an expository tool.")
(substitute* "collects/racket/system.rkt"
(("/bin/sh") (which "sh")))
#t)))
- #:tests? #f ; XXX: how to run them?
+ #:tests? #f ; XXX: how to run them?
))
(inputs
`(("libffi" ,libffi)
@@ -503,7 +508,7 @@ implementation techniques and as an expository tool.")
("glib" ,glib)
("glu" ,glu)
("gmp" ,gmp)
- ("gtk+" ,gtk+) ; propagates gdk-pixbuf+svg
+ ("gtk+" ,gtk+) ; propagates gdk-pixbuf+svg
("libjpeg" ,libjpeg)
("libpng" ,libpng)
("libx11" ,libx11)
@@ -512,7 +517,8 @@ implementation techniques and as an expository tool.")
("openssl" ,openssl)
("pango" ,pango)
("sqlite" ,sqlite)
- ("unixodbc" ,unixodbc)))
+ ("unixodbc" ,unixodbc)
+ ("libedit" ,libedit)))
(home-page "http://racket-lang.org")
(synopsis "Implementation of Scheme and related languages")
(description