summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm36
1 files changed, 24 insertions, 12 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 359a345029..db2a75d1d3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -64,19 +65,22 @@
(define-public cifs-utils
(package
(name "cifs-utils")
- (version "6.13")
+ (version "6.14")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/linux-cifs/"
"cifs-utils/cifs-utils-" version ".tar.bz2"))
(sha256 (base32
- "0mnhcc4ayj2vn2azhk45fnal1hibsv0q2c4ihkxcrjhkhrn7in23"))))
+ "1f2n0yzqsy5v5qv83731bi0mi86rrh11z8qjy1gjj8al9c3yh2b6"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+
+ ;; To generate the manpages.
+ ("python-docutils" ,python-docutils))) ; rst2man
(inputs
`(("keytuils" ,keyutils)
("linux-pam" ,linux-pam)
@@ -85,23 +89,31 @@
("samba" ,samba)
("talloc" ,talloc)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--enable-man")
+ #:phases
(modify-phases %standard-phases
+ (add-before 'bootstrap 'trigger-bootstrap
+ ;; The shipped configure script is buggy, e.g., it contains a
+ ;; unexpanded literal ‘LIBCAP_NG_PATH’ line).
+ (lambda _
+ (delete-file "configure")))
(add-before 'configure 'set-root-sbin
(lambda* (#:key outputs #:allow-other-keys)
;; Don't try to install into "/sbin".
(setenv "ROOTSBINDIR"
- (string-append (assoc-ref outputs "out") "/sbin"))
- #t))
- (add-before 'install 'create-man8dir
+ (string-append (assoc-ref outputs "out") "/sbin"))))
+ (add-before 'install 'install-man-pages
;; Create a directory that isn't created since version 6.10.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/share/man/man8"))
- #t))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "install-man"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(synopsis "User-space utilities for Linux CIFS (Samba) mounts")
(description "@code{cifs-utils} is a set of user-space utilities for
-mounting and managing @dfn{Common Internet File System} (CIFS) shares using
+mounting and managing @acronym{CIFS, Common Internet File System} shares using
the Linux kernel CIFS client.")
(home-page "https://wiki.samba.org/index.php/LinuxCIFS_utils")
;; cifs-utils is licensed as GPL3 or later, but 3 files contain LGPL code.