summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 46b97215ba..c147abcaab 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -114,11 +114,13 @@ anywhere.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib")))
- ;; Add LIB to the RUNPATH of all the executables.
+ ;; Add LIB to the RUNPATH of all the executables and
+ ;; dynamic libraries.
(with-directory-excursion out
(for-each (cut augment-rpath <> lib)
(append (find-files "bin" ".*")
- (find-files "sbin" ".*"))))))
+ (find-files "sbin" ".*")
+ (find-files "lib" ".*"))))))
%standard-phases))
#:modules ((guix build gnu-build-system)