summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index a749f5633a..2cc50f7b6a 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -275,7 +275,7 @@ on numerical types, while GiNaC depends on CLN for this purpose.")
(define-public zn-poly
(package
(name "zn-poly")
- (version "0.9.1")
+ (version "0.9.2")
(source
(origin
(method git-fetch)
@@ -285,8 +285,7 @@ on numerical types, while GiNaC depends on CLN for this purpose.")
(commit version)))
(file-name (git-file-name "zn_poly" version))
(sha256
- (base32
- "0ra5vy585bqq7g3317iw6fp44iqgqvds3j0l1va6mswimypq4vxb"))))
+ (base32 "1wbc3apxcldxfcw1dnwnn7fvlfb6bwvlr8glvgv6hf79p9r2s4j0"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2)))
@@ -332,7 +331,7 @@ coefficients of which are modular integers.")
(define-public brial
(package
(name "brial")
- (version "1.2.5")
+ (version "1.2.6")
(source
(origin
(method git-fetch)
@@ -341,8 +340,7 @@ coefficients of which are modular integers.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1nv56fp3brpzanxj7vwvxqdafqfsfhdgq5imr3m94psw5gdfqwja"))))
+ (base32 "1mc1zjr3mxcx6bg0js5k9jx65japg7644b0aj1al75m4nwh2ygab"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -365,7 +363,7 @@ for the underlying polynomial rings and subsets of the powerset of the
Boolean variables. As a unique approach, binary decision diagrams are
used as internal storage type for polynomial structures.")
(license license:gpl2+)
- (home-page "https://gitlab.com/sagemath/zn_poly")))
+ (home-page "https://github.com/BRiAl/BRiAl/")))
(define-public lcalc
(package