summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 2dedef8373..af4d322a73 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -229,18 +229,21 @@ rustc-bootstrap and cargo-bootstrap packages.")
(("/usr/bin/env") (which "env")))
;; Avoid curl as a build dependency.
(substitute* "configure"
- (("probe_need CFG_CURL curl") ""))))
+ (("probe_need CFG_CURL curl") ""))
+ #t))
(add-after 'unpack 'set-env
(lambda _
(setenv "SHELL" (which "sh"))
- (setenv "CONFIG_SHELL" (which "sh"))))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ #t))
(add-after 'unpack 'patch-tests
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/tools/tidy/src/main.rs"
- (("^.*cargo.*::check.*$") ""))
- (substitute* "src/libstd/process.rs"
- (("\"/bin/sh\"") (string-append "\"" (assoc-ref inputs "bash") "/bin/sh\"")))
- #t))
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "src/tools/tidy/src/main.rs"
+ (("^.*cargo.*::check.*$") ""))
+ (substitute* "src/libstd/process.rs"
+ (("\"/bin/sh\"") (string-append "\"" bash "/bin/sh\"")))
+ #t)))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -275,7 +278,8 @@ rustc-bootstrap and cargo-bootstrap packages.")
;; Let gcc find ld and libc startup files.
(wrap-program (string-append out "/bin/rustc")
`("PATH" ":" prefix (,(string-append ld-wrapper "/bin")))
- `("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))))))))
+ `("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))
+ #t))))))
;; rustc invokes gcc, so we need to set its search paths accordingly.
(native-search-paths (package-native-search-paths gcc))
(synopsis "Compiler for the Rust progamming language")