summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 7dd60dd35b..556ff04940 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -685,6 +686,51 @@ your current directory for a regex pattern while respecting your
gitignore rules.")
(license (list license:unlicense license:expat))))
+(define-public git-interactive-rebase-tool
+ (package
+ (name "git-interactive-rebase-tool")
+ (version "2.1.0")
+ (source
+ (origin
+ ;; crates.io does not provide the test data.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitmaro/git-interactive-rebase-tool")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "173spqqpyc00kvfmldjmjfqizh9b4spq4xw4bskd4dny8qcpz28d"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags
+ ;; https://github.com/MitMaro/git-interactive-rebase-tool/issues/586
+ '("--release" "--" "--skip=tests::success")
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-crossterm" ,rust-crossterm-0.19)
+ ("rust-git2" ,rust-git2-0.13)
+ ("rust-num-format" ,rust-num-format-0.4)
+ ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-xi-unicode" ,rust-xi-unicode-0.3))
+ #:cargo-development-inputs
+ (("rust-concat-idents" ,rust-concat-idents-1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-rstest" ,rust-rstest-0.6)
+ ("rust-serial-test" ,rust-serial-test-0.5)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (inputs
+ (list zlib))
+ (home-page "https://gitrebasetool.mitmaro.ca/")
+ (synopsis "Terminal based sequence editor for git interactive rebase")
+ (description
+ "This application is a terminal-based sequence editor for git interactive
+rebase.")
+ (license license:gpl3+)))
+
(define-public rust-cbindgen
(package
(name "rust-cbindgen")
@@ -1328,6 +1374,31 @@ library and a dynamic library, and a C header to be used by any C (and
C-compatible) software.")
(license license:expat)))
+(define-public swayhide
+ (package
+ (name "swayhide")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swayhide" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0x172ffj0lfmbv5nix708l1mfsizxzy74gpxp5amvx0bbaq0p78s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-exitcode" ,rust-exitcode-1)
+ ("rust-swayipc" ,rust-swayipc-2))))
+ (home-page "https://github.com/NomisIV/swayhide/")
+ (synopsis "Swallow windows on swaywm")
+ (description "swayhide hides the currently active terminal (by moving it
+to the scratchpad), then it executes the supplied command. When the child
+process has finished, the terminal is moved back. This is useful if your
+workflow includes opening graphical programs from the terminal, as the locked
+terminal won't have to take up any space.")
+ (license license:gpl3+)))
+
(define-public tealdeer
(package
(name "tealdeer")
@@ -1437,6 +1508,7 @@ Full featured offline client with caching support.")
(substitute* "Cargo.toml"
(("2.5") "2")
(("~2.3\"") "2\"")
+ (("~2.33\"") "2\"") ; clap
(("3.1") "3"))))
(add-after 'install 'install-manual-page
(lambda* (#:key outputs #:allow-other-keys)