summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b181d1dc1f..7348f29eb1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -648,8 +648,8 @@ outcomes of a code example.")
(synopsis "Ripper-style abstract syntax tree to Ruby source generator")
(description "Sorcerer generates Ruby code from a Ripper-like abstract
syntax tree (i.e. S-Expressions). Sorcerer is targeted mainly at small
-snippets of Ruby code, expressable in a single line. Longer examples may be
-re-sourced, but they will be rendered in a single line format.")
+snippets of Ruby code, expressible in a single line. Longer examples may be
+re-sourced, but they will be rendered in a single-line format.")
(home-page "https://github.com/rspec-given/sorcerer")
(license license:expat)))
@@ -1115,7 +1115,7 @@ line of code.")
#t))
(add-after 'unpack 'patch-pandoc-path
(lambda* (#:key inputs #:allow-other-keys)
- (let ((pandoc (string-append (assoc-ref inputs "ghc-pandoc")
+ (let ((pandoc (string-append (assoc-ref inputs "pandoc")
"/bin/pandoc")))
(substitute* "lib/pandoc-ruby.rb"
(("@@pandoc_path = 'pandoc'")
@@ -1135,7 +1135,7 @@ line of code.")
(native-inputs
`(("ruby-mocha" ,ruby-mocha)))
(inputs
- `(("ghc-pandoc" ,ghc-pandoc)))
+ `(("pandoc" ,pandoc)))
(synopsis "Ruby wrapper for Pandoc")
(description "PandocRuby is a wrapper for Pandoc, a Haskell library with
command line tools for converting one markup format to another. Pandoc can
@@ -7792,7 +7792,7 @@ master/html-formatter/ruby")
(native-inputs
`(;; Use a untested version of aruba, to avoid a circular dependency, as
;; ruby-aruba depends on ruby-cucumber.
- ("ruby-aruba", ruby-aruba-without-tests)
+ ("ruby-aruba" ,ruby-aruba-without-tests)
("ruby-rspec" ,ruby-rspec)
("ruby-pry" ,ruby-pry)
("ruby-nokogiri" ,ruby-nokogiri)
@@ -8851,7 +8851,7 @@ display width of strings in Ruby.")
(native-inputs
`(("ruby-rdoc" ,ruby-rdoc)
("ruby-rspec" ,ruby-rspec)
- ("ruby-rubygems-tasks", ruby-rubygems-tasks)))
+ ("ruby-rubygems-tasks" ,ruby-rubygems-tasks)))
(synopsis "Ruby library to help check the Ruby version")
(description "@code{ruby_version} provides a @code{RubyVersion} module to simplify
checking for the right Ruby version in software.")
@@ -9963,7 +9963,7 @@ all known public suffixes.")
("bundler" ,bundler)
("ruby-idn-ruby" ,ruby-idn-ruby)
("ruby-sporkmonger-rack-mount" ,ruby-sporkmonger-rack-mount)
- ("ruby-rspec-its", ruby-rspec-its-minimal)
+ ("ruby-rspec-its" ,ruby-rspec-its-minimal)
("ruby-yard" ,ruby-yard)
("ruby-simplecov" ,ruby-simplecov)))
(propagated-inputs