summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 29d17f0755..2bd6fc21cf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4978,10 +4978,16 @@ both CSS3 selector and XPath 1.0 support.")
"1pnyh44qycnf9mzi1j6fywd5fkskv3x7nmsqrrws0rjn5dd4ayfp"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"))
+ `(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-git-ls-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Rakefile"
+ (("git ls-files") "find . -type f"))
+ #t)))))
(native-inputs
- `(("ruby-rspec" ,ruby-rspec)
- ("git" ,git)))
+ `(("ruby-rspec" ,ruby-rspec)))
(synopsis "Retrieve the source code for Ruby methods")
(description "Method_source retrieves the source code for Ruby methods.
Additionally, it can extract source code from Proc and Lambda objects or just