summaryrefslogtreecommitdiff
path: root/gnu/packages/rrdtool.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rrdtool.scm')
-rw-r--r--gnu/packages/rrdtool.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/rrdtool.scm b/gnu/packages/rrdtool.scm
index 13419e4d37..4390c5b0ca 100644
--- a/gnu/packages/rrdtool.scm
+++ b/gnu/packages/rrdtool.scm
@@ -55,13 +55,12 @@
("pango" ,pango)
("python" ,python-2)))
(native-inputs
- `(("groff" ,groff)
- ("pkg-config" ,pkg-config)
-
- ;; For tests.
- ("bc" ,bc)
- ("perl" ,perl) ; will also build Perl bindings
- ("tzdata" ,tzdata-for-tests)))
+ (list groff
+ pkg-config
+ ;; For tests.
+ bc
+ perl ; will also build Perl bindings
+ tzdata-for-tests))
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -73,9 +72,7 @@
(add-before 'check 'prepare-test-environment
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t))
+ (search-input-directory inputs "share/zoneinfo"))))
(add-after 'install 'remove-native-input-references
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))