summaryrefslogtreecommitdiff
path: root/gnu/packages/rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rpc.scm')
-rw-r--r--gnu/packages/rpc.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/rpc.scm b/gnu/packages/rpc.scm
index f02fa66f6c..b4f4af9446 100644
--- a/gnu/packages/rpc.scm
+++ b/gnu/packages/rpc.scm
@@ -105,11 +105,7 @@
(find-files "." "\\.a$"))))
#t)))))
(inputs
- `(("abseil-cpp" ,abseil-cpp)
- ("c-ares" ,c-ares/cmake)
- ("openssl" ,openssl)
- ("re2" ,re2)
- ("zlib" ,zlib)))
+ (list abseil-cpp c-ares/cmake openssl re2 zlib))
(native-inputs
`(("pkg-config" ,pkg-config)
("protobuf" ,protobuf)
@@ -152,11 +148,11 @@ browsers to backend services.")
"src/core/lib/gpr/log_posix.cc"
"src/core/lib/iomgr/ev_epollex_linux.cc")
(("gettid\\(")
- "sys_gettid("))
- #t))))))
+ "sys_gettid("))))))))
(native-inputs
- `(("protobuf" ,protobuf-3.6)
- ,@(alist-delete "protobuf" (package-native-inputs grpc))))))
+ (modify-inputs (package-native-inputs grpc)
+ (delete "abseil-cpp" "protobuf")
+ (prepend abseil-cpp-20200923.3 protobuf-3.6)))))
(define-public python-grpcio
(package
@@ -199,11 +195,9 @@ browsers to backend services.")
(("'cc'") "'gcc'"))
#t)))))
(inputs
- `(("c-ares" ,c-ares)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list c-ares openssl zlib))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(home-page "https://grpc.io")
(synopsis "HTTP/2-based RPC framework")
(description "This package provides a Python library for communicating
@@ -230,15 +224,14 @@ with the HTTP/2-based RPC framework gRPC.")
(list (string-append "--with-boost="
(assoc-ref %build-inputs "boost")))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("flex" ,flex)
- ("bison" ,bison)))
+ (list autoconf
+ automake
+ libtool
+ pkg-config
+ flex
+ bison))
(inputs
- `(("boost" ,boost)
- ("libressl" ,libressl)))
+ (list boost libressl))
(outputs '("out" "lib" "include"))
(home-page "https://thrift.apache.org/")
(synopsis