summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 3f9987d0ae..812aa310c4 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -82,7 +82,7 @@
(source
(origin (method git-fetch)
(uri (git-reference
- (url "https://github.com/jgaeddert/liquid-dsp.git")
+ (url "https://github.com/jgaeddert/liquid-dsp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -113,7 +113,7 @@ mathematical operations, and much more.")
(origin
(method git-fetch)
(uri (git-reference
- (url "git://git.osmocom.org/rtl-sdr.git")
+ (url "https://git.osmocom.org/rtl-sdr/")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -548,7 +548,7 @@ to the fix block above.
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/csete/gqrx.git")
+ (url "https://github.com/csete/gqrx")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -618,14 +618,14 @@ hardware.")
(define-public flrig
(package
(name "flrig")
- (version "1.3.50")
+ (version "1.3.51")
(source
(origin
(method url-fetch)
(uri (string-append "http://www.w1hkj.com/files/flrig/flrig-"
version ".tar.gz"))
(sha256
- (base32 "0fzrknzzi8kmzmrcfpc8rxr7v4a4ny6z6z5q5qwh95sp2kn2qzp9"))))
+ (base32 "0aq4x0ai9q08ypfhzfj2inc4z3q39zq1l6h9as1kil9yn4zbay61"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -665,7 +665,7 @@ or USB connection.")
("libxft" ,libxft)))
(synopsis "Tool for AMP file transfer")
(description
- "FLAMP is a program for transfering files by radio waves using AMP
+ "FLAMP is a program for transferring files by radio waves using AMP
(Amateur Multicast Protocol).")
(home-page "http://www.w1hkj.com/")
(license license:gpl3+)))
@@ -712,7 +712,7 @@ for correctness.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mossmann/hackrf.git")
+ (url "https://github.com/mossmann/hackrf")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -801,7 +801,7 @@ users.")
(package
(inherit hamlib)
(name "wsjtx-hamlib")
- (version "2.2.1")
+ (version "2.2.2")
(source
(origin
(method git-fetch)
@@ -835,7 +835,7 @@ users.")
(define-public wsjtx
(package
(name "wsjtx")
- (version "2.2.1")
+ (version "2.2.2")
(source
(origin
(method git-fetch)
@@ -844,7 +844,7 @@ users.")
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12i8ch2yhxlbd7lbpl4s4y37ks4i00wasah4j44g104rxrzdny57"))
+ (base32 "0fhws44gg05d9y2al0pcdnxwxwh4bazcfl0g5mq2ks1r7w23wi5x"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -896,14 +896,14 @@ weak-signal conditions.")
(package
(inherit wsjtx)
(name "js8call")
- (version "2.1.1")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
(uri (string-append "http://files.js8call.com/" version
"/js8call-" version ".tgz"))
(sha256
- (base32 "034jnv6h172znn9ijl6wpmzx0rqibb69ppg52ndvkxhqlgrbsvyc"))
+ (base32 "149sjwc4zg6ckgq26af93p4fxappa4k9dh7rdy67g8ajfjad4cd8"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -921,7 +921,7 @@ weak-signal conditions.")
`(("boost" ,boost)
("fftw" ,fftw)
("fftwf" ,fftwf)
- ("hamlib" ,hamlib)
+ ("hamlib" ,wsjtx-hamlib)
("libusb" ,libusb)
("qtbase" ,qtbase)
("qtmultimedia" ,qtmultimedia)
@@ -1025,7 +1025,7 @@ gain and standing wave ratio.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/flightaware/dump1090.git")
+ (url "https://github.com/flightaware/dump1090")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1067,7 +1067,7 @@ their position, altitude, speed, etc.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/merbanan/rtl_433.git")
+ (url "https://github.com/merbanan/rtl_433")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1093,7 +1093,7 @@ from devices on the 433 MHz, 868 MHz, 315 MHz, 345 MHz and 915 MHz ISM bands.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/EliasOenal/multimon-ng.git")
+ (url "https://github.com/EliasOenal/multimon-ng")
(commit version)))
(file-name (git-file-name name version))
(sha256