summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm211
1 files changed, 104 insertions, 107 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 79d41b3e73..526054c896 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -346,7 +346,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtbase
(package
(name "qtbase")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -355,12 +355,11 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
- "12mjsahlma9rw3vz9a6b5h2s6ylg8b34hxc2vnlna5ll429fgfa8"))
+ "1y70libf2x52lpbqvhz10lpk7nyl1ajjwzjxly9pjdpfj4jsv7wh"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"
"qtbase-moc-ignore-gcc-macro.patch"
- "qtbase-absolute-runpath.patch"
- "qtbase-fix-krita-deadlock.patch"))
+ "qtbase-absolute-runpath.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -608,7 +607,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -617,7 +616,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
- "18dmfc8s428fzbk7k5vl3212b25455ayrz7s716nwyiy3ahgmmy7"))))
+ "0pjqrdmd1991x9h4rl8sf81pkd89hfd5h1a2gp3fjw96pk0w5hwb"))))
(propagated-inputs `())
(native-inputs `(("perl" ,perl)))
(inputs
@@ -683,7 +682,7 @@ HostData=lib/qt5
(define-public qtimageformats
(package (inherit qtsvg)
(name "qtimageformats")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -692,7 +691,7 @@ HostData=lib/qt5
version ".tar.xz"))
(sha256
(base32
- "132g4rlm61pdcpcrclr1rwpbrxn7va4wjfb021mh8pn1cl0wlgkk"))
+ "1msk8a0z8rr16hkp2fnv668vf6wayiydqgc2mcklaa04rv3qb0mz"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -724,7 +723,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(define-public qtx11extras
(package (inherit qtsvg)
(name "qtx11extras")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -733,7 +732,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
version ".tar.xz"))
(sha256
(base32
- "0njlh6d327nll7d8qaqrwr5x15m9yzgyar2j45qigs1f7ah896my"))))
+ "0gkfzj195v9flwljnqpdz3a532618yn4h2577nlsai56x4p7053h"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -748,7 +747,7 @@ from within Qt 5.")))
(define-public qtxmlpatterns
(package (inherit qtsvg)
(name "qtxmlpatterns")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -757,7 +756,7 @@ from within Qt 5.")))
version ".tar.xz"))
(sha256
(base32
- "1dyg1z4349k04yyzn8xbp4f5qjgm60gz6wgzp80khpilcmk8g6i1"))))
+ "1ypj5jpa31rlx8yfw3y9jia212lfnxvnqkvygs6ihjf3lxi23skn"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f) ; TODO: Enable the tests
@@ -779,7 +778,7 @@ xmlpatternsvalidator.")))
(define-public qtdeclarative
(package (inherit qtsvg)
(name "qtdeclarative")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -788,7 +787,7 @@ xmlpatternsvalidator.")))
version ".tar.xz"))
(sha256
(base32
- "0l0nhc2si6dl9r4s1bs45z90qqigs8jnrsyjjdy38q4pvix63i53"))))
+ "0lancdn7y0lrlmyn5cbdm0izd5yprvd5n77nhkb7a3wl2sbx0066"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f) ;TODO: Enable the tests
@@ -823,7 +822,7 @@ with JavaScript and C++.")))
(define-public qtconnectivity
(package (inherit qtsvg)
(name "qtconnectivity")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -832,7 +831,7 @@ with JavaScript and C++.")))
version ".tar.xz"))
(sha256
(base32
- "0a5wzin635b926b8prdwfazgy1vhyf8m6an64wp2lpkp78z7prmb"))))
+ "185zci61ip1wpjrygcw2m6v55lvninc0b8y2p3jh6qgpf5w35003"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)
@@ -847,7 +846,7 @@ with Bluetooth and NFC.")))
(define-public qtwebsockets
(package (inherit qtsvg)
(name "qtwebsockets")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -856,7 +855,7 @@ with Bluetooth and NFC.")))
version ".tar.xz"))
(sha256
(base32
- "116amx4mnv50k0fpswgpr5x8wjny8nbffrjmld01pzhkhfqn4vph"))))
+ "0gr399fn5n8j3m9d3vv01vcbr1cb7pw043j04cnnxzrlvn2jvd50"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -874,7 +873,7 @@ consume data received from the server, or both.")))
(define-public qtsensors
(package (inherit qtsvg)
(name "qtsensors")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -883,7 +882,7 @@ consume data received from the server, or both.")))
version ".tar.xz"))
(sha256
(base32
- "0qccpgbhyg9k4x5nni7xm0pyvaqia3zrcd42cn7ksf5h21lwmkxw"))))
+ "0fa81r7bn1mf9ynwsx524a55dx1q0jb4vda6j48ssb4lx7wi201z"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:parallel-tests? _ #f) #f) ; can lead to race condition
@@ -907,7 +906,7 @@ recognition API for devices.")))
(define-public qtmultimedia
(package (inherit qtsvg)
(name "qtmultimedia")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -916,7 +915,7 @@ recognition API for devices.")))
version ".tar.xz"))
(sha256
(base32
- "1sczzcvk3c5gczz53yvp8ma6gp8aixk5pcq7wh344c9md3g8xkbs"))
+ "1xbd6kc7i0iablqdkvfrajpi32cbq7j6ajbfyyyalcai1s0mhdqc"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -958,7 +957,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(define-public qtwayland
(package (inherit qtsvg)
(name "qtwayland")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -967,13 +966,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
version ".tar.xz"))
(sha256
(base32
- "0al3yypy3fin62n8d1859jh0mn0fbpa161l7f37hgd4gf75365nk"))
- (modules '((guix build utils)))
- (snippet
- ;; The examples try to build and cause the build to fail
- '(begin
- (delete-file-recursively "examples")
- #t))))
+ "1ddfx4nak16xx0zh1kl836zxvpbixmmjyplsmfmg65pqkwi34dqr"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1010,6 +1003,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
("mesa" ,mesa)
("mtdev" ,mtdev)
("qtbase" ,qtbase)
+ ("vulkan-headers" ,vulkan-headers)
("wayland" ,wayland)))
(synopsis "Qt Wayland module")
(description "The Qt Wayland module provides the QtWayland client and
@@ -1018,7 +1012,7 @@ compositor libraries.")))
(define-public qtserialport
(package (inherit qtsvg)
(name "qtserialport")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1027,7 +1021,7 @@ compositor libraries.")))
version ".tar.xz"))
(sha256
(base32
- "08ga9a1lwj83872nxablk602z1dq0la6jqsiicvd7m1sfbfpgnd6"))))
+ "17gp5qzg4wdg8qlxk2p3mh8x1vk33rf33wic3fy0cws193bmkiar"))))
(native-inputs `(("perl" ,perl)))
(inputs
`(("qtbase" ,qtbase)
@@ -1052,7 +1046,7 @@ interacting with serial ports from within Qt.")))
(define-public qtserialbus
(package (inherit qtsvg)
(name "qtserialbus")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1061,7 +1055,7 @@ interacting with serial ports from within Qt.")))
version ".tar.xz"))
(sha256
(base32
- "14bahg82jciciqkl74q9hvf3a8kp3pk5v731vp2416k4b8bn4xqb"))))
+ "125x6756fjpldqy6wbw6cg7ngjh2016aiq92bchh719z1mf7xsxf"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases '%standard-phases)
@@ -1087,7 +1081,7 @@ and others.")))
(define-public qtwebchannel
(package (inherit qtsvg)
(name "qtwebchannel")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1096,7 +1090,7 @@ and others.")))
version ".tar.xz"))
(sha256
(base32
- "0x7q66994pw6cd0f505bmirw1sssqs740zaw8lyqqqr32m2ch7bx"))))
+ "1h9y634phvvk557mhmf9z4lmxr41rl8x9mqy2lzp31mk8ffffzqj"))))
(native-inputs
`(("perl" ,perl)
("qtdeclarative" ,qtdeclarative)
@@ -1111,7 +1105,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(define-public qtwebglplugin
(package (inherit qtsvg)
(name "qtwebglplugin")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1120,7 +1114,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
version ".tar.xz"))
(sha256
(base32
- "05rl657848fsprsnabdqb5z363c6drjc32k59223vl351f8ihhgb"))))
+ "0ihlnhv8ldkqz82v3j7j22lrhk17b6ghra8sx85y2agd2ysq5rw1"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1147,7 +1141,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(define-public qtwebview
(package (inherit qtsvg)
(name "qtwebview")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1156,7 +1150,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
version ".tar.xz"))
(sha256
(base32
- "0jzzcm7z5njkddzfhmyjz4dbbzq8h93980cci4479zc4xq9r47y6"))))
+ "1rw1wibmbxlj6xc86qs3y8h42al1vczqiksyxzaylxs9gqb4d7xy"))))
(native-inputs
`(("perl" ,perl)))
(inputs
@@ -1170,7 +1164,7 @@ native APIs where it makes sense.")))
(define-public qtlocation
(package (inherit qtsvg)
(name "qtlocation")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1179,7 +1173,7 @@ native APIs where it makes sense.")))
version ".tar.xz"))
(sha256
(base32
- "1k3m8zhbv04yrqvj7jlnh8f9xczdsmla59j9gcwsqvbg76y0hxy3"))))
+ "184jychnlfhplpwc5cdcsapwljgwvzk5qpf3val4kpq8w44wnkwq"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1200,7 +1194,7 @@ positioning and geolocation plugins.")))
(define-public qttools
(package (inherit qtsvg)
(name "qttools")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1209,7 +1203,7 @@ positioning and geolocation plugins.")))
version ".tar.xz"))
(sha256
(base32
- "1iakl3hlyg51ri1czmis8mmb257b0y1zk2a2knybd3mq69wczc2v"))))
+ "1k618f7v6jaj0ygy8d7jvgb8zjr47sn55kiskbdkkizp3z7d12f1"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1228,7 +1222,7 @@ that helps in Qt development.")))
(define-public qtscript
(package (inherit qtsvg)
(name "qtscript")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1237,7 +1231,7 @@ that helps in Qt development.")))
version ".tar.xz"))
(sha256
(base32
- "1zlvg3hc6h70d789g3kv6dxbwswzkskkm00bdgl01grwrdy4izg9"))
+ "0gk74hk488k9ldacxbxcranr3arf8ifqg8kz9nm1rgdgd59p36d2"))
(patches (search-patches "qtscript-disable-tests.patch"))))
(native-inputs
`(("perl" ,perl)
@@ -1252,7 +1246,7 @@ ECMAScript and Qt.")))
(define-public qtquickcontrols
(package (inherit qtsvg)
(name "qtquickcontrols")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1261,7 +1255,7 @@ ECMAScript and Qt.")))
version ".tar.xz"))
(sha256
(base32
- "0qa4dlhn3iv9yvaic8hw86v6h8rn9sgq8xjfdaym04pfshfyypfm"))))
+ "1dczakl868mg0lnwpf082jjc5976ycn879li1vqlgw5ihirzp4y3"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1276,7 +1270,7 @@ can be used to build complete interfaces in Qt Quick.")))
(define-public qtquickcontrols2
(package (inherit qtsvg)
(name "qtquickcontrols2")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1285,7 +1279,7 @@ can be used to build complete interfaces in Qt Quick.")))
version ".tar.xz"))
(sha256
(base32
- "0q0mk2mjlf9ll0gdrdzxy8096s6g9draaqiwrlvdpa7lv14x7xzs"))))
+ "06c9vrwvbjmzapmfa25y34lgjkzg57xxbm92nr6wkv5qykjnq6v7"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1301,7 +1295,7 @@ not available.")))
(define-public qtgraphicaleffects
(package (inherit qtsvg)
(name "qtgraphicaleffects")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1310,7 +1304,7 @@ not available.")))
version ".tar.xz"))
(sha256
(base32
- "03xmwhapv0b2qj661iaqqrvhxc7qiid0acrp6rj85824ha2pyyj8"))))
+ "1r6zfc0qga2ax155js7c8y5rx6vgayf582s921j09mb797v6g3gc"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1328,7 +1322,7 @@ coloring, and many more.")))
(define-public qtgamepad
(package (inherit qtsvg)
(name "qtgamepad")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1337,7 +1331,7 @@ coloring, and many more.")))
version ".tar.xz"))
(sha256
(base32
- "00wd3h465waxdghg2vdhs5pkj0xikwjn88l12477dksm8zdslzgp"))))
+ "0p07bg93fdfn4gr2kv38qgnws5znhswajrxdfs8xc9l3i7vi2xn7"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))
@@ -1358,7 +1352,7 @@ and mobile applications targeting TV-like form factors.")))
(define-public qtscxml
(package (inherit qtsvg)
(name "qtscxml")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1367,7 +1361,7 @@ and mobile applications targeting TV-like form factors.")))
version ".tar.xz"))
(sha256
(base32
- "141pfschv6zmcvvn3pi7f5vb4nf96zpngy80f9bly1sn58syl303"))
+ "1p5771b9hnpchfcdgy0zkhwg09a6xq88934aggp0rij1k85mkfb0"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1389,7 +1383,7 @@ also contains functionality to support data models and executable content.")))
(define-public qtpurchasing
(package (inherit qtsvg)
(name "qtpurchasing")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1398,7 +1392,7 @@ also contains functionality to support data models and executable content.")))
version ".tar.xz"))
(sha256
(base32
- "0lg8x7g7dkf95xwxq8b4yw4ypdz68igkscya96xwbklg3q08gc39"))))
+ "09rjx53519dfk4qj2gbn3vlxyriasyb747wpg1p11y7jkwqhs4l7"))))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
@@ -1409,7 +1403,7 @@ purchasing goods and services.")))
(define-public qtcharts
(package (inherit qtsvg)
(name "qtcharts")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1418,7 +1412,7 @@ purchasing goods and services.")))
version ".tar.xz"))
(sha256
(base32
- "1drvm15i6n10b6a1acgarig120ppvqh3r6fqqdn8i3blx81m5cmd"))))
+ "049x7z8zcp9jixmdv2fjscy2ggpd6za9hkdbb2bqp2mxjm0hwxg0"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1436,7 +1430,7 @@ selecting one of the charts themes.")
(define-public qtdatavis3d
(package (inherit qtsvg)
(name "qtdatavis3d")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1445,7 +1439,7 @@ selecting one of the charts themes.")
version ".tar.xz"))
(sha256
(base32
- "080fkpxg70m3c697wfnkjhca58b7r1xsqd559jzb21985pdh6g3j"))))
+ "1zdn3vm0nfy9ny7c783aabp3mhlnqhi9fw2rljn7ibbksmsnasi2"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1463,7 +1457,7 @@ customized by using themes or by adding custom items and labels to them.")
(define-public qtnetworkauth
(package (inherit qtsvg)
(name "qtnetworkauth")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1472,7 +1466,7 @@ customized by using themes or by adding custom items and labels to them.")
version ".tar.xz"))
(sha256
(base32
- "0pi6p7bq54kzij2p69cgib7n55k69jsq0yqq09yli645s4ym202g"))))
+ "11fdgacv4syr8bff2vdw7rb0dg1gcqpdf37hm3pn31d6z91frhpw"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1492,7 +1486,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(define-public qtremoteobjects
(package (inherit qtsvg)
(name "qtremoteobjects")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1501,7 +1495,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
version ".tar.xz"))
(sha256
(base32
- "1mhlws5w0igf5hw0l90p6dz6k7w16dqfbnk2li0zxdmayk2039m6"))))
+ "1hngbp0vkr35rpsrac7b9vx6f360v8v2g0fffzm590l8j2ybd0b7"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1529,7 +1523,7 @@ processes or computers.")))
(define-public qtspeech
(package (inherit qtsvg)
(name "qtspeech")
- (version "5.14.2")
+ (version "5.15.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1538,7 +1532,7 @@ processes or computers.")))
version ".tar.xz"))
(sha256
(base32
- "1nn6kspbp8hfkz1jhzc1qx1m9z7r1bgkdqgi9n4vl1q25yk8x7jy"))))
+ "1xc3x3ghnhgchsg1kgj156yg69wn4rwjx8r28i1jd05hxjggn468"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
@@ -1603,7 +1597,7 @@ using the Enchant spell-checking library.")
version ".tar.xz"))
(sha256
(base32
- "0iy9lsl6zxlkca6x2p1506hbj3wmhnaipg23z027wfccbnkxcsg1"))
+ "1q4idxdm81sx102xc12ixj0xpfx52d6vwvs3jpapnkyq8c7cmby8"))
(modules '((ice-9 ftw)
(ice-9 match)
(srfi srfi-1)
@@ -1612,8 +1606,9 @@ using the Enchant spell-checking library.")
(snippet
'(begin
(let ((preserved-third-party-files
- '("base/third_party/cityhash"
- "base/third_party/dmg_fp"
+ '("base/third_party/double_conversion"
+ "base/third_party/cityhash"
+ "base/third_party/cityhash_v103"
"base/third_party/dynamic_annotations"
"base/third_party/icu"
"base/third_party/libevent"
@@ -1636,19 +1631,26 @@ using the Enchant spell-checking library.")
"third_party/blink"
"third_party/boringssl"
"third_party/boringssl/src/third_party/fiat"
- "third_party/boringssl/src/third_party/sike"
- "third_party/boringssl/linux-x86_64/crypto/third_party/sike"
- "third_party/boringssl/linux-aarch64/crypto/third_party/sike"
"third_party/breakpad"
"third_party/brotli"
"third_party/ced"
"third_party/cld_3"
+ "third_party/closure_compiler"
+ "third_party/crashpad"
+ "third_party/crashpad/crashpad/third_party/lss"
+ "third_party/crashpad/crashpad/third_party/zlib"
"third_party/crc32c"
"third_party/dav1d"
"third_party/dawn"
+ "third_party/devtools-frontend"
+ "third_party/devtools-frontend/src/front_end/third_party/fabricjs"
+ "third_party/devtools-frontend/src/front_end/third_party/lighthouse"
+ "third_party/devtools-frontend/src/front_end/third_party/wasmparser"
+ "third_party/devtools-frontend/src/third_party/axe-core"
"third_party/emoji-segmenter"
"third_party/ffmpeg"
"third_party/googletest"
+ "third_party/harfbuzz-ng/utils"
"third_party/hunspell"
"third_party/iccjpeg"
"third_party/icu"
@@ -1659,8 +1661,9 @@ using the Enchant spell-checking library.")
"third_party/khronos"
"third_party/leveldatabase"
"third_party/libaddressinput"
+ "third_party/libgifcodec"
"third_party/libjingle_xmpp"
- "third_party/libjpeg"
+ "third_party/libjpeg_turbo"
"third_party/libpng"
"third_party/libsrtp"
"third_party/libsync"
@@ -1672,6 +1675,7 @@ using the Enchant spell-checking library.")
"third_party/libxslt"
"third_party/libyuv"
"third_party/lss"
+ "third_party/mako"
"third_party/markupsafe"
"third_party/mesa_headers"
"third_party/metrics_proto"
@@ -1680,18 +1684,25 @@ using the Enchant spell-checking library.")
"third_party/one_euro_filter"
"third_party/opus"
"third_party/ots"
+ "third_party/pdfium"
+ "third_party/pdfium/third_party/agg23"
+ "third_party/pdfium/third_party/base"
+ "third_party/pdfium/third_party/freetype"
+ "third_party/pdfium/third_party/lcms"
+ "third_party/pdfium/third_party/libopenjpeg20"
+ "third_party/pdfium/third_party/skia_shared"
"third_party/perfetto"
"third_party/pffft"
"third_party/ply"
"third_party/polymer"
"third_party/protobuf"
+ "third_party/protobuf/third_party/six"
"third_party/pyjson5"
"third_party/re2"
"third_party/rnnoise"
"third_party/skia"
"third_party/skia/include/third_party/skcms/skcms.h"
"third_party/skia/include/third_party/vulkan"
- "third_party/skia/third_party/gif"
"third_party/skia/third_party/skcms"
"third_party/skia/third_party/vulkanmemoryallocator"
"third_party/smhasher"
@@ -1792,7 +1803,7 @@ using the Enchant spell-checking library.")
(("third_party/curl") "curl"))
(substitute*
'("components/viz/common/gpu/vulkan_context_provider.h"
- "components/viz/common/resources/resource_format_utils.h"
+ "components/viz/common/resources/resource_format_utils_vulkan.h"
"gpu/config/gpu_util.cc")
(("third_party/vulkan/include/")
""))
@@ -1818,6 +1829,7 @@ using the Enchant spell-checking library.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-2" ,python-2)
+ ("python-six" ,python2-six)
("ruby" ,ruby)))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -1872,23 +1884,6 @@ using the Enchant spell-checking library.")
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
`(modify-phases ,phases
- (add-after 'unpack 'fix-build-with-newer-re2
- (lambda _
- ;; Adjust for API change in re2, taken from
- ;; https://chromium-review.googlesource.com/c/chromium/src/+/2145261
- (substitute* "src/3rdparty/chromium/components/autofill/core\
-/browser/address_rewriter.cc"
- (("options\\.set_utf8\\(true\\)")
- "options.set_encoding(RE2::Options::EncodingUTF8)"))
- #t))
- (add-after 'unpack 'patch-ninja-version-check
- (lambda _
- ;; The build system assumes the system Ninja is too old because
- ;; it only checks for versions 1.7 through 1.9. We have 1.10.
- (substitute* "configure.pri"
- (("1\\.\\[7-9\\]\\.\\*")
- "1.([7-9]|1[0-9]).*"))
- #t))
(add-before 'configure 'substitute-source
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -1950,15 +1945,17 @@ and binaries removed, and adds modular support for using system libraries.")
(define-public python-sip
(package
(name "python-sip")
- (version "4.19.22")
+ (version "4.19.24")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.riverbankcomputing.com/static/"
- "Downloads/sip/" version "/sip-" version ".tar.gz"))
+ (uri (list (pypi-uri "sip" version)
+ (string-append "https://www.riverbankcomputing.com/static/"
+ "Downloads/sip/" version
+ "/sip-" version ".tar.gz")))
(sha256
(base32
- "0idywc326l8v1m3maprg1aq2gph67mmnnsskvlwfx8n19s16idz1"))))
+ "1ra15vb5i9gkg2vdvh16cq9x2mmzw1yi3xphxs8q34q1pf83gkgd"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-wrapper)))
@@ -2008,7 +2005,7 @@ module provides support functions to the automatically generated code.")
(define-public python-pyqt
(package
(name "python-pyqt")
- (version "5.14.2")
+ (version "5.15.2")
(source
(origin
(method url-fetch)
@@ -2021,7 +2018,7 @@ module provides support functions to the automatically generated code.")
(file-name (string-append "PyQt5-"version ".tar.gz"))
(sha256
(base32
- "1c4y4qi1l540gd125ikj0al00k5pg65kmqaixcfbzslrsrphq8xx"))
+ "1z74295i69cha52llsqffzhb5zz7qnbjc64h8qg21l91jgf0harp"))
(patches (search-patches "pyqt-configure.patch"
"pyqt-public-sip.patch"))))
(build-system gnu-build-system)
@@ -2100,7 +2097,7 @@ contain over 620 classes.")
(define-public python-pyqtwebengine
(package
(name "python-pyqtwebengine")
- (version "5.14.0")
+ (version "5.15.2")
(source
(origin
(method url-fetch)
@@ -2112,7 +2109,7 @@ contain over 620 classes.")
"/PyQtWebEngine-" version ".tar.gz")))
(sha256
(base32
- "14hw49akb35n9pgiw564x8ykmsifihn9p2ax2x4zmywb3w2ra5g1"))))
+ "0d56ak71r14w4f9r96vaj34qcn2rbln3s6ildvvyc707fjkzwwjd"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python)
@@ -2298,15 +2295,15 @@ itself.")
(define-public qscintilla
(package
(name "qscintilla")
- (version "2.10.8")
+ (version "2.11.6")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/pyqt/QScintilla2/"
- "QScintilla-" version "/QScintilla_gpl-"
- version ".tar.gz"))
+ (uri (string-append "https://www.riverbankcomputing.com/static"
+ "/Downloads/QScintilla/" version
+ "/QScintilla-" version ".tar.gz"))
(sha256
(base32
- "1swjr786w04r514pry9pn32ivza4il1cg35s60qy39cwc175pka6"))))
+ "19r0vpqb4m9bqwxmjp9w6x0hgahkrg7zryk78hwgplj7vdbn0d77"))))
(build-system gnu-build-system)
(arguments
`(#:phases