summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6ca052c31a..c9ac750cc5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -149,7 +149,7 @@ system, and the core design of Django is reused in Grantlee.")
(version "4.8.7")
(source (origin
(method url-fetch)
- (uri (string-append "http://download.qt-project.org/official_releases/qt/"
+ (uri (string-append "http://download.qt-project.org/archive/qt/"
(string-copy version 0 (string-rindex version #\.))
"/" version
"/qt-everywhere-opensource-src-"
@@ -2040,7 +2040,10 @@ contain over 620 classes.")
("qtwebengine" ,qtwebengine)))
(arguments
`(#:modules ((srfi srfi-1)
+ ((guix build python-build-system) #:select (python-version))
,@%gnu-build-system-modules)
+ #:imported-modules ((guix build python-build-system)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -2050,13 +2053,8 @@ contain over 620 classes.")
(pyqt-sipdir (string-append
(assoc-ref inputs "python-pyqt") "/share/sip"))
(python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2) "."))
(lib (string-append out "/lib/python"
- python-major+minor
+ (python-version python)
"/site-packages/PyQt5"))
(stubs (string-append lib "/PyQt5")))
@@ -2075,7 +2073,9 @@ contain over 620 classes.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((__init__.py (string-append
(assoc-ref outputs "out")
- "/lib/python3.7/site-packages/PyQt5/__init__.py")))
+ "/lib/python"
+ (python-version (assoc-ref inputs "python"))
+ "/site-packages/PyQt5/__init__.py")))
(with-output-to-file __init__.py
(lambda _ (display "
from pkgutil import extend_path
@@ -2373,7 +2373,7 @@ different kinds of sliders, and much more.")
(define-public qtwebkit
(package
(name "qtwebkit")
- (version "5.212.0-alpha3")
+ (version "5.212.0-alpha4")
(source
(origin
(method url-fetch)
@@ -2381,12 +2381,12 @@ different kinds of sliders, and much more.")
"qtwebkit-" version "/qtwebkit-" version ".tar.xz"))
(sha256
(base32
- "05syvwi3jw9abwsc93rmjkna0vyh6bkfrsqhwir48ms54icfwzim"))
+ "1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
(patches (search-patches "qtwebkit-pbutils-include.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)
- ("python" ,python-2.7)
+ ("python" ,python)
("ruby" ,ruby)
("bison" ,bison)
("flex" ,flex)