summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4625d2220d..ff9a99c672 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -169,9 +169,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "qt5ct.pro"
(("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (string-append (assoc-ref inputs "qttools")
- "/bin/lrelease")))
- #t))
+ (search-input-file inputs "/bin/lrelease")))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
@@ -2682,7 +2680,11 @@ different kinds of sliders, and much more.")
(sha256
(base32
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
- (patches (search-patches "qtwebkit-pbutils-include.patch"))))
+ (patches (search-patches "qtwebkit-pbutils-include.patch"
+ "qtwebkit-fix-building-with-bison-3.7.patch"
+ "qtwebkit-fix-building-with-glib-2.68.patch"
+ "qtwebkit-fix-building-with-icu-68.patch"
+ "qtwebkit-fix-building-with-python-3.9.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)
@@ -2731,7 +2733,19 @@ different kinds of sliders, and much more.")
;; libraries and test executables in a
;; reasonable amount of memory.
"-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
- "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
+ "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ ;; This is a workaround for the build failing with the error:
+ ;; ld: error adding symbols: Malformed archive
+ ;; Increasing the maximum number of open file descriptors
+ ;; makes the build succeed.
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (let ((cmd (format #f
+ "ulimit -n 4096; make ~{~a~^ ~}"
+ make-flags)))
+ (invoke "sh" "-c" cmd)))))))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")