summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm62
1 files changed, 60 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ee903ecae9..a596ca4ce6 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -18,6 +18,8 @@
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 TomZ <tomz@freedommail.ch>
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +57,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
@@ -72,6 +75,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages ninja)
#:use-module (gnu packages nss)
#:use-module (gnu packages pciutils)
@@ -695,6 +699,16 @@ HostData=lib/qt5
'(begin
(delete-file-recursively "src/3rdparty")
#t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "src/plugins/imageformats/jp2/qjp2handler.cpp"
+ (("^#include <jasper/jasper.h>")
+ "#include <jasper/jasper.h>\n#include <QtCore/qmath.h>"))
+ #t))))))
(native-inputs `())
(inputs
`(("jasper" ,jasper)
@@ -1049,8 +1063,22 @@ interacting with serial ports from within Qt.")))
(sha256
(base32
"14bahg82jciciqkl74q9hvf3a8kp3pk5v731vp2416k4b8bn4xqb"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'patch-libsocketcan-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((libcansocket (assoc-ref inputs "libsocketcan"))
+ (libcansocket.so (string-append libcansocket
+ "/lib/libsocketcan.so")))
+ (substitute* "src/plugins/canbus/socketcan/libsocketcan.cpp"
+ (("QStringLiteral\\(\"socketcan\"\\)")
+ (format #f "QStringLiteral(~s)" libcansocket.so)))
+ #t)))))))
(inputs
- `(("qtbase" ,qtbase)
+ `(("libsocketcan" ,libsocketcan)
+ ("qtbase" ,qtbase)
("qtserialport" ,qtserialport)))
(synopsis "Qt Serial Bus module")
(description "The Qt Serial Bus API provides classes and functions to
@@ -1532,6 +1560,36 @@ the end-user is driving and cannot attend the incoming messages on the phone.
In such a scenario, the messaging application can read out the incoming
message.")))
+(define-public qtspell
+ (package
+ (name "qtspell")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/manisandro/qtspell.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1081makirjxixz44ghwz362vgnk5wcks6ni6w01pl667x8wggsd2"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no test
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("qtbase" ,qtbase)))
+ (home-page "https://github.com/manisandro/qtspell")
+ (synopsis "Spell checking for Qt text widgets")
+ (description
+ "QtSpell adds spell-checking functionality to Qt's text widgets,
+using the Enchant spell-checking library.")
+ ;; COPYING file specify GPL3, but source code files all refer to GPL2+.
+ (license license:gpl2+)))
+
(define-public qtwebengine
(package
(inherit qtsvg)