summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm353
1 files changed, 233 insertions, 120 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a15d6453c9..cefceb6b68 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -105,7 +105,7 @@ system, and the core design of Django is reused in Grantlee.")
(define-public qt
(package
(name "qt")
- (version "5.9.4")
+ (version "5.11.1")
(outputs '("out" "examples"))
(source (origin
(method url-fetch)
@@ -114,11 +114,11 @@ system, and the core design of Django is reused in Grantlee.")
"http://download.qt.io/official_releases/qt/"
(version-major+minor version)
"/" version
- "/single/qt-everywhere-opensource-src-"
+ "/single/qt-everywhere-src-"
version ".tar.xz"))
(sha256
(base32
- "1mblh8k04l13nk9fhhrr43h5bcph1gbz94j5y7csx8zvxb5xkb73"))
+ "0azva1wx298jh0xskymz8jic83yhxs1xfxf321wqd5lwiyq2qq1r"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -135,7 +135,7 @@ system, and the core design of Django is reused in Grantlee.")
(lambda (dir)
(delete-file-recursively (string-append "qtbase/src/3rdparty/" dir)))
(list "double-conversion" "freetype" "harfbuzz-ng"
- "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
+ "libpng" "libjpeg" "pcre2" "xcb"
"xkbcommon" "zlib"))
(for-each
(lambda (dir)
@@ -143,10 +143,23 @@ system, and the core design of Django is reused in Grantlee.")
(list "qtimageformats/src/3rdparty"
"qtmultimedia/examples/multimedia/spectrum/3rdparty"
"qtwayland/examples"
+ "qtscxml/tests/3rdparty"
"qtcanvas3d/examples/canvas3d/3rdparty"))
;; Tests depend on this example, which depends on the 3rd party code.
(substitute* "qtmultimedia/examples/multimedia/multimedia.pro"
(("spectrum") "#"))
+ (substitute* "qtxmlpatterns/tests/auto/auto.pro"
+ (("qxmlquery") "# qxmlquery")
+ (("xmlpatterns ") "# xmlpatterns"))
+ (substitute* "qtwebglplugin/tests/plugins/platforms/platforms.pro"
+ (("webgl") "# webgl"))
+ (substitute* "qtscxml/tests/auto/auto.pro"
+ (("scion") "#"))
+ (substitute* "qtnetworkauth/tests/auto/auto.pro"
+ (("oauth1 ") "# oauth1 "))
+ (substitute* "qtremoteobjects/tests/auto/qml/qml.pro"
+ (("integration") "# integration")
+ (("usertypes") "# usertypes"))
#t))))
(build-system gnu-build-system)
(propagated-inputs
@@ -193,7 +206,7 @@ system, and the core design of Django is reused in Grantlee.")
("postgresql" ,postgresql)
("pulseaudio" ,pulseaudio)
("pcre2" ,pcre2)
- ("sqlite" ,sqlite)
+ ;("sqlite" ,sqlite)
("udev" ,eudev)
("unixodbc" ,unixodbc)
("wayland" ,wayland)
@@ -213,7 +226,8 @@ system, and the core design of Django is reused in Grantlee.")
("ruby" ,ruby)
("which" ,(@ (gnu packages base) which))))
(arguments
- `(#:phases
+ `(#:parallel-build? #f ; Triggers race condition in qtbase module on Hydra.
+ #:phases
(modify-phases %standard-phases
(add-after 'configure 'patch-bin-sh
(lambda _
@@ -236,16 +250,32 @@ system, and the core design of Django is reused in Grantlee.")
"./configure"
"-verbose"
"-prefix" out
- "-examplesdir" examples ; 89MiB
+ "-docdir" (string-append out "/share/doc/qt5")
+ "-headerdir" (string-append out "/include/qt5")
+ "-archdatadir" (string-append out "/lib/qt5")
+ "-datadir" (string-append out "/share/qt5")
+ "-examplesdir" (string-append
+ examples "/share/doc/qt5/examples") ; 151MiB
"-opensource"
"-confirm-license"
+
+ ;; These features require higher versions of Linux than the
+ ;; minimum version of the glibc. See
+ ;; src/corelib/global/minimum-linux_p.h. By disabling these
+ ;; features Qt5 applications can be used on the oldest
+ ;; kernels that the glibc supports, including the RHEL6
+ ;; (2.6.32) and RHEL7 (3.10) kernels.
+ "-no-feature-getentropy" ; requires Linux 3.17
+ "-no-feature-renameat2" ; requires Linux 3.16
+
;; Do not build examples; for the time being, we
;; prefer to save the space and build time.
"-no-compile-examples"
;; Most "-system-..." are automatic, but some use
;; the bundled copy by default.
- "-system-sqlite"
+ ;"-system-sqlite"
"-system-harfbuzz"
+ "-system-pcre"
;; explicitly link with openssl instead of dlopening it
"-openssl-linked"
;; explicitly link with dbus instead of dlopening it
@@ -260,12 +290,92 @@ system, and the core design of Django is reused in Grantlee.")
'()
'("-no-sse2"))
"-no-mips_dsp"
- "-no-mips_dspr2"))))))))
- (home-page "https://www.qt.io/")
- (synopsis "Cross-platform GUI library")
- (description "Qt is a cross-platform application and UI framework for
-developers using C++ or QML, a CSS & JavaScript like language.")
- (license license:lgpl2.1)
+ "-no-mips_dspr2")))))
+ (add-after 'install 'patch-mkspecs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (archdata (string-append out "/lib/qt5"))
+ (mkspecs (string-append archdata "/mkspecs"))
+ (qt_config.prf (string-append
+ mkspecs "/features/qt_config.prf")))
+ ;; For each Qt module, let `qmake' uses search paths in the
+ ;; module directory instead of all in QT_INSTALL_PREFIX.
+ (substitute* qt_config.prf
+ (("\\$\\$\\[QT_INSTALL_HEADERS\\]")
+ "$$clean_path($$replace(dir, mkspecs/modules, ../../include/qt5))")
+ (("\\$\\$\\[QT_INSTALL_LIBS\\]")
+ "$$clean_path($$replace(dir, mkspecs/modules, ../../lib))")
+ (("\\$\\$\\[QT_HOST_LIBS\\]")
+ "$$clean_path($$replace(dir, mkspecs/modules, ../../lib))")
+ (("\\$\\$\\[QT_INSTALL_BINS\\]")
+ "$$clean_path($$replace(dir, mkspecs/modules, ../../bin))"))
+
+ ;; Searches Qt tools in the current PATH instead of QT_HOST_BINS.
+ (substitute* (string-append mkspecs "/features/qt_functions.prf")
+ (("cmd = \\$\\$\\[QT_HOST_BINS\\]/\\$\\$2")
+ "cmd = $$system(which $${2}.pl 2>/dev/null || which $${2})"))
+
+ ;; Resolve qmake spec files within qtbase by absolute paths.
+ (substitute*
+ (map (lambda (file)
+ (string-append mkspecs "/features/" file))
+ '("device_config.prf" "moc.prf" "qt_build_config.prf"
+ "qt_config.prf" "winrt/package_manifest.prf"))
+ (("\\$\\$\\[QT_HOST_DATA/get\\]") archdata)
+ (("\\$\\$\\[QT_HOST_DATA/src\\]") archdata))
+ #t)))
+ (add-after 'unpack 'patch-paths
+ ;; Use the absolute paths for dynamically loaded libs, otherwise
+ ;; the lib will be searched in LD_LIBRARY_PATH which typically is
+ ;; not set in guix.
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; libresolve
+ (let ((glibc (assoc-ref inputs ,(if (%current-target-system)
+ "cross-libc" "libc"))))
+ (substitute* '("qtbase/src/network/kernel/qdnslookup_unix.cpp"
+ "qtbase/src/network/kernel/qhostinfo_unix.cpp")
+ (("^\\s*(lib.setFileName\\(QLatin1String\\(\")(resolv\"\\)\\);)" _ a b)
+ (string-append a glibc "/lib/lib" b))))
+ ;; X11/locale (compose path)
+ (substitute* "qtbase/src/plugins/platforminputcontexts/compose/generator/qtablegenerator.cpp"
+ ;; Don't search in /usr/…/X11/locale, …
+ (("^\\s*m_possibleLocations.append\\(QStringLiteral\\(\"/usr/.*/X11/locale\"\\)\\);" line)
+ (string-append "// " line))
+ ;; … but use libx11's path
+ (("^\\s*(m_possibleLocations.append\\(QStringLiteral\\()X11_PREFIX \"(/.*/X11/locale\"\\)\\);)" _ a b)
+ (string-append a "\"" (assoc-ref inputs "libx11") b)))
+ ;; libGL
+ (substitute* "qtbase/src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp"
+ (("^\\s*(QLibrary lib\\(QLatin1String\\(\")(GL\"\\)\\);)" _ a b)
+ (string-append a (assoc-ref inputs "mesa") "/lib/lib" b)))
+ ;; libXcursor
+ (substitute* "qtbase/src/plugins/platforms/xcb/qxcbcursor.cpp"
+ (("^\\s*(QLibrary xcursorLib\\(QLatin1String\\(\")(Xcursor\"\\), 1\\);)" _ a b)
+ (string-append a (assoc-ref inputs "libxcursor") "/lib/lib" b))
+ (("^\\s*(xcursorLib.setFileName\\(QLatin1String\\(\")(Xcursor\"\\)\\);)" _ a b)
+ (string-append a (assoc-ref inputs "libxcursor") "/lib/lib" b)))
+ #t)))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "QMAKEPATH")
+ (files '("lib/qt5")))
+ (search-path-specification
+ (variable "QML2_IMPORT_PATH")
+ (files '("lib/qt5/qml")))
+ (search-path-specification
+ (variable "QT_PLUGIN_PATH")
+ (files '("lib/qt5/plugins")))
+ (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))
+ (search-path-specification
+ (variable "XDG_CONFIG_DIRS")
+ (files '("etc/xdg")))))
+ (home-page "https://www.qt.io/")
+ (synopsis "Cross-platform GUI library")
+ (description "Qt is a cross-platform application and UI framework for
+ developers using C++ or QML, a CSS & JavaScript like language.")
+ (license (list license:lgpl2.1 license:lgpl3))
;; Qt 4: 'QBasicAtomicPointer' leads to build failures on MIPS;
;; see <http://hydra.gnu.org/build/112828>.
@@ -373,7 +483,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtbase
(package
(name "qtbase")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -382,7 +492,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
- "0rny87ypnkkvyp9p76nim77v6np0cdf1dbjfmcilklzphkdlcvpd"))
+ "0ipv18ypbgpxhh49rfplqmflskmnhhwj1bjr5hrwi0jpvar4gl50"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"))
(modules '((guix build utils)))
@@ -616,7 +726,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -625,7 +735,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
- "0m0zglp0m5gv75ivma6l3hm8brb0cf44dhbc6lqwfdwacxhgx3jb"))))
+ "0drhig0jcss3cf01aqfmafajf8gzf6bh468g1ikyrkh46czgyshx"))))
(propagated-inputs `())
(native-inputs `(("perl" ,perl)))
(inputs
@@ -691,7 +801,7 @@ HostData=lib/qt5
(define-public qtimageformats
(package (inherit qtsvg)
(name "qtimageformats")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -700,7 +810,7 @@ HostData=lib/qt5
version ".tar.xz"))
(sha256
(base32
- "0w0yy7zzln3v7dm7ksjxkzhq8r0a9nwk823wv4f1x7vsa3pnyh2q"))
+ "05jnyrq7klr3mdiz0r9c151vl829yc8y9cxfbw5dwbp1rkndwl7b"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -722,7 +832,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(define-public qtx11extras
(package (inherit qtsvg)
(name "qtx11extras")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -731,7 +841,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
version ".tar.xz"))
(sha256
(base32
- "13vbx61wcd8pnpgk3j5r665pm03s7jp2s98apvc6fhp1njlr0rhi"))))
+ "0rccpmhz48kq4xs441lj9mnwpbi6kxwl8y7dj7w7g5zvpv41kwmw"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -746,7 +856,7 @@ from within Qt 5.")))
(define-public qtxmlpatterns
(package (inherit qtsvg)
(name "qtxmlpatterns")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -755,7 +865,7 @@ from within Qt 5.")))
version ".tar.xz"))
(sha256
(base32
- "13nj2pa706sy874bqbv7y94ypicr4k09x6n2jyxkw93flb5pi8qr"))))
+ "0n5gacpni019i2872m4b1p5qaqibhszsdl3xhw3xsckvr0hf25v1"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -775,7 +885,7 @@ xmlpatternsvalidator.")))
(define-public qtdeclarative
(package (inherit qtsvg)
(name "qtdeclarative")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -784,7 +894,7 @@ xmlpatternsvalidator.")))
version ".tar.xz"))
(sha256
(base32
- "1h2pbyr7dnak4q96373xpa6gk6rl528rnqima8xnvhdi2y5kgagf"))))
+ "0fjg9ii64mhx2ww70rj44cy65rwwkwyjxcm435kwp3v1pzv5xkwy"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -807,7 +917,7 @@ with JavaScript and C++.")))
(define-public qtconnectivity
(package (inherit qtsvg)
(name "qtconnectivity")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -816,7 +926,7 @@ with JavaScript and C++.")))
version ".tar.xz"))
(sha256
(base32
- "0wqq5q5saf007aphvpn5pvj6l0qp0z7wxvfba6v9iq5ylyqm6bnd"))))
+ "0mz6mbf069yqdvi6mcvp6izskcn9wzig4s3dzmygwd430pmx93kk"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)
@@ -831,7 +941,7 @@ with Bluetooth and NFC.")))
(define-public qtwebsockets
(package (inherit qtsvg)
(name "qtwebsockets")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -840,7 +950,7 @@ with Bluetooth and NFC.")))
version ".tar.xz"))
(sha256
(base32
- "1drr6nxxbkwpmz39bhyfmmsqjhy11bj3w1nc3q9dwhpcbf04an3x"))))
+ "1bj82y3f1nd2adnj3ljfr4vlx4bkgdlm3zvhlsas2lz837vi5aks"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -858,7 +968,7 @@ consume data received from the server, or both.")))
(define-public qtsensors
(package (inherit qtsvg)
(name "qtsensors")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -867,7 +977,7 @@ consume data received from the server, or both.")))
version ".tar.xz"))
(sha256
(base32
- "1az22rdkpc1m44qb3dyh7cpiprplkvynzjr629ai05i8ngbfdi0g"))))
+ "1yn065l6kzs3fn74950pkxxglqi55lzk7alf15klsd1wnxc0zsfb"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:parallel-tests? _ #f) #f) ; can lead to race condition
@@ -891,7 +1001,7 @@ recognition API for devices.")))
(define-public qtmultimedia
(package (inherit qtsvg)
(name "qtmultimedia")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -900,7 +1010,7 @@ recognition API for devices.")))
version ".tar.xz"))
(sha256
(base32
- "0g4x1w251imq58zp1px6yschwj6icsxzwl3fy7pjfbgd27qjhlzg"))
+ "0369b0mh7sr718l119b07grb1v8xqlq6l4damyd6lrmlj1wbb2zj"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -942,7 +1052,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(define-public qtwayland
(package (inherit qtsvg)
(name "qtwayland")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -951,7 +1061,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
version ".tar.xz"))
(sha256
(base32
- "09s1ckqj0cgjmmi7jylsf039vgzlq7i9rr4swb590fkz427lx0b8"))
+ "1sj4lsza48xji1qhmi1wqpx07jgm1mpa95gmd2w1kxw240hbr6p0"))
(modules '((guix build utils)))
(snippet
;; The examples try to build and cause the build to fail
@@ -994,7 +1104,7 @@ compositor libraries.")))
(define-public qtserialport
(package (inherit qtsvg)
(name "qtserialport")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1003,7 +1113,7 @@ compositor libraries.")))
version ".tar.xz"))
(sha256
(base32
- "1cbf1jsginp5p3y17cyb6dfhsafxal0bn9pya6aybz0q799zgvl5"))))
+ "18v4pbq7bnmrl81m8s11ksbjlvzbb4kw5py6ji2dhmnm44w9k9sn"))))
(native-inputs `(("perl" ,perl)))
(inputs
`(("qtbase" ,qtbase)
@@ -1028,7 +1138,7 @@ interacting with serial ports from within Qt.")))
(define-public qtserialbus
(package (inherit qtsvg)
(name "qtserialbus")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1037,7 +1147,7 @@ interacting with serial ports from within Qt.")))
version ".tar.xz"))
(sha256
(base32
- "0r3crk7gw0xs6wk1gvw2k8r9s9vam3sfwrji1njhswavii9fbp85"))))
+ "0jjmdd6vkvs5izqazp1rsrad0b1fzk6knrbdjl37lvcsawyfxfyk"))))
(inputs
`(("qtbase" ,qtbase)
("qtserialport" ,qtserialport)))
@@ -1049,7 +1159,7 @@ and others.")))
(define-public qtwebchannel
(package (inherit qtsvg)
(name "qtwebchannel")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1058,7 +1168,7 @@ and others.")))
version ".tar.xz"))
(sha256
(base32
- "05fa5pwvk24cjp8m6pbw3ma95vnls762crpjdgvygfk0h8xilxmh"))))
+ "11rfjkb4h8dzxfmk889x7kkc73cbk26smc7h62lnh35f2nppd95r"))))
(native-inputs
`(("perl" ,perl)
("qtdeclarative" ,qtdeclarative)
@@ -1073,7 +1183,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(define-public qtwebglplugin
(package (inherit qtsvg)
(name "qtwebglplugin")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1082,11 +1192,20 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
version ".tar.xz"))
(sha256
(base32
- "1al7dv7i9rg4z4p8vnipbjbbgc6113lbfjggxxap3sn6hqs986fm"))))
+ "108yhi3sj6d1ysmlpka69ivb20mx9h6jpra6yq099i3jw4gc753x"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'disable-network-tests
+ (lambda _ (substitute* "tests/plugins/platforms/platforms.pro"
+ (("webgl") "# webgl"))
+ #t))))))
(native-inputs '())
(inputs
`(("mesa" ,mesa)
("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
("qtwebsockets" ,qtwebsockets)))
(synopsis "QPA plugin for running an application via a browser using
streamed WebGL commands")
@@ -1099,7 +1218,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(define-public qtwebview
(package (inherit qtsvg)
(name "qtwebview")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1108,7 +1227,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
version ".tar.xz"))
(sha256
(base32
- "0a89v8mj5pb7a7whyhasf4ms0n34ghfmv2qp0pyxnq56f2bsjbl4"))))
+ "18da6a13wpb23vb6mbg9v75gphdf5mjmch7q3v1qjrv2sdwbpjbp"))))
(native-inputs
`(("perl" ,perl)))
(inputs
@@ -1122,7 +1241,7 @@ native APIs where it makes sense.")))
(define-public qtlocation
(package (inherit qtsvg)
(name "qtlocation")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1131,7 +1250,7 @@ native APIs where it makes sense.")))
version ".tar.xz"))
(sha256
(base32
- "074cjqhr14mqlsqj9rzagzdcqnayyichp31lq02k05q07wg93xi8"))))
+ "03vrbymwbn4nqsypcmr4ccqv20nvwdfs9gb01pi3jxr6x0wrlb0p"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1152,7 +1271,7 @@ positioning and geolocation plugins.")))
(define-public qttools
(package (inherit qtsvg)
(name "qttools")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1161,7 +1280,7 @@ positioning and geolocation plugins.")))
version ".tar.xz"))
(sha256
(base32
- "1nb77bfs63nyy0wkhsci9qbqmahncy3sdcrwj4qr1prc4y2cm4wx"))))
+ "1zhl8p29mbabf07rhaks13qcm45zdckzymvz9qn95nxfj9piiyxp"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1179,7 +1298,7 @@ that helps in Qt development.")))
(define-public qtscript
(package (inherit qtsvg)
(name "qtscript")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1188,7 +1307,7 @@ that helps in Qt development.")))
version ".tar.xz"))
(sha256
(base32
- "1ib8a5gsxarbm2j94j5d097ly3ap4snqkx2imz3sl6xk6gknm4i5"))
+ "0z6sb4b9ds5lwkr0sxrnx6nim3aq2qx4a8illjy5vclfdv80yhqw"))
(patches (search-patches "qtscript-disable-tests.patch"))))
(native-inputs
`(("perl" ,perl)
@@ -1203,7 +1322,7 @@ ECMAScript and Qt.")))
(define-public qtquickcontrols
(package (inherit qtsvg)
(name "qtquickcontrols")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1212,7 +1331,7 @@ ECMAScript and Qt.")))
version ".tar.xz"))
(sha256
(base32
- "01ziibf4afdhb5b3gfci8maprmviqwhdvma2z1jlq2ck45cpsqi6"))))
+ "0mn662j0gkpama7zlrsn4h27sjrk49kpbha1h0zxxyiza5cpzsms"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1227,7 +1346,7 @@ can be used to build complete interfaces in Qt Quick.")))
(define-public qtquickcontrols2
(package (inherit qtsvg)
(name "qtquickcontrols2")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1236,7 +1355,7 @@ can be used to build complete interfaces in Qt Quick.")))
version ".tar.xz"))
(sha256
(base32
- "1hsa8n4dlqpyz9xq2kq1hsxrxsjc7ywzzfhqijylgzzclvlqgb7y"))))
+ "0hn4kvrkz5ivwrp9p6yzwlw7cn4j72kcpm2nqyi3dbai1px6dc5x"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1252,7 +1371,7 @@ not available.")))
(define-public qtgraphicaleffects
(package (inherit qtsvg)
(name "qtgraphicaleffects")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1261,7 +1380,7 @@ not available.")))
version ".tar.xz"))
(sha256
(base32
- "0xzr4421w7idlgndxnd68wwc2asabycjiskkyl1f8nwqv34lcy3j"))))
+ "1ws8aj7bq3rxpzjs370dcyqk8a5v1y6fwvrdhf70j8b2d4v75lnr"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1307,7 +1426,7 @@ backend for QtQuick scene graph.")
(define-public qtgamepad
(package (inherit qtsvg)
(name "qtgamepad")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1316,7 +1435,7 @@ backend for QtQuick scene graph.")
version ".tar.xz"))
(sha256
(base32
- "0g52c03gdgz57h7szdxvc5hdy45l7q7m29yfzhwqc57hwdfl98bi"))))
+ "1n97w9rcbg8mzkvjgn3i8jbfmplp7w0p80ykdchpml47gxk1kwma"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))
@@ -1337,7 +1456,7 @@ and mobile applications targeting TV-like form factors.")))
(define-public qtscxml
(package (inherit qtsvg)
(name "qtscxml")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1346,7 +1465,7 @@ and mobile applications targeting TV-like form factors.")))
version ".tar.xz"))
(sha256
(base32
- "00wb89ris8fyivhz9qpqn72mzpkh6mqdjss82j3q10g3c142072k"))
+ "0f1k4fnk2aydagxqvkb636pcsi17sbq2zj2fn0ad50dvq013yiph"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1368,7 +1487,7 @@ also contains functionality to support data models and executable content.")))
(define-public qtpurchasing
(package (inherit qtsvg)
(name "qtpurchasing")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1377,7 +1496,7 @@ also contains functionality to support data models and executable content.")))
version ".tar.xz"))
(sha256
(base32
- "1c92yv2yi38sic06nyr9r6zpq3y4sxnasmj14d3jmg50gc1ncqfs"))))
+ "0crm39fy9aqns10mjlbxvkkna9xklic49zfp3f7v7cwl66wap6dc"))))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
@@ -1388,7 +1507,7 @@ purchasing goods and services.")))
(define-public qtcanvas3d
(package (inherit qtsvg)
(name "qtcanvas3d")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1397,7 +1516,7 @@ purchasing goods and services.")))
version ".tar.xz"))
(sha256
(base32
- "1kqcaks6lkz8cp9s3pwrvgrr8381rjzf5fbf2bzshdw7psphxiiz"))
+ "1pif3m1f44jrly2nh0hzid6dmdxqiy5qgx645hz6g5fmpl113d8g"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1427,7 +1546,7 @@ drawing calls from Qt Quick JavaScript.")))
(define-public qtcharts
(package (inherit qtsvg)
(name "qtcharts")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1436,7 +1555,7 @@ drawing calls from Qt Quick JavaScript.")))
version ".tar.xz"))
(sha256
(base32
- "0lg39vd6i0l76spjz6bhb1kkpbk2mgc0hxccj7733xxbxaz14vn4"))))
+ "0avscsni84zrzydilkkp456sbaypyzhkn42qygjdq7wcn045zxk2"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1454,7 +1573,7 @@ selecting one of the charts themes.")
(define-public qtdatavis3d
(package (inherit qtsvg)
(name "qtdatavis3d")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1463,7 +1582,7 @@ selecting one of the charts themes.")
version ".tar.xz"))
(sha256
(base32
- "1s7gmgh6g3aia74yiqahffrc6n8f4491vb7g3i4i10ilandipg34"))))
+ "0gay0dsz05xfrlx190y95hp9wipzb988h02fqbqvyn00ds3s178w"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1481,7 +1600,7 @@ customized by using themes or by adding custom items and labels to them.")
(define-public qtnetworkauth
(package (inherit qtsvg)
(name "qtnetworkauth")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1490,7 +1609,7 @@ customized by using themes or by adding custom items and labels to them.")
version ".tar.xz"))
(sha256
(base32
- "1kr8hwjsb8a5cypvqj48vrnkcvm2rcni102dh6i909i70a7hcsym"))))
+ "05p4pvfp3k5612d54anvpj39bgc7v572x6kgk3fy69xgn7lhbd02"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1510,7 +1629,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(define-public qtremoteobjects
(package (inherit qtsvg)
(name "qtremoteobjects")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1519,7 +1638,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
version ".tar.xz"))
(sha256
(base32
- "1chn1xxhapfwvhrlv4chwfgf2dw8x8kn1lssdmpmg5s420z3pbq9"))))
+ "1yv9f2329nv4viiyqmq7ciz51574wd11grj8s88qm0ndcb36jbgb"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@@ -1528,7 +1647,8 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(lambda _
;; This test can't find its imports.
(substitute* "tests/auto/qml/qml.pro"
- (("integration") "# integration"))
+ (("integration") "# integration")
+ (("usertypes") "# usertypes"))
#t))))))
(inputs
`(("qtbase" ,qtbase)
@@ -1542,7 +1662,7 @@ processes or computers.")))
(define-public qtspeech
(package (inherit qtsvg)
(name "qtspeech")
- (version "5.11.0")
+ (version "5.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@@ -1551,7 +1671,10 @@ processes or computers.")))
version ".tar.xz"))
(sha256
(base32
- "1bgfg0akqf1nfzm28n8dhvhj0p1niwxrfs763gj7m0g6vpwjbhd1"))))
+ "1nwvbaijg35i98yaiqgnyn5vv0cn4v3wrxhwi1s0hfv9sv3q5iyw"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:tests? _ #f) #f))) ; TODO: Enable the tests
(inputs
`(("qtbase" ,qtbase)))
(native-inputs
@@ -1571,7 +1694,7 @@ message.")))
(define-public python-sip
(package
(name "python-sip")
- (version "4.19.8")
+ (version "4.19.12")
(source
(origin
(method url-fetch)
@@ -1580,7 +1703,7 @@ message.")))
"sip-" version "/sip-" version ".tar.gz"))
(sha256
(base32
- "1g4pq9vj753r2s061jc4y9ydzgb48ibhc9bdvmb8mlyllwp7mbvy"))))
+ "08iqj9qyanc6a4bllbd87gv8pd1gkplw1jhfa1sz0gcq3g1pyq94"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-wrapper)))
@@ -1605,11 +1728,10 @@ message.")))
(lib (string-append out "/lib/python"
python-major+minor
"/site-packages")))
- (zero?
- (system* "python" "configure.py"
- "--bindir" bin
- "--destdir" lib
- "--incdir" include))))))))
+ (invoke "python" "configure.py"
+ "--bindir" bin
+ "--destdir" lib
+ "--incdir" include)))))))
(home-page "https://www.riverbankcomputing.com/software/sip/intro")
(synopsis "Python binding creator for C and C++ libraries")
(description
@@ -1634,7 +1756,7 @@ module provides support functions to the automatically generated code.")
(define-public python-pyqt
(package
(name "python-pyqt")
- (version "5.10.1")
+ (version "5.11.2")
(source
(origin
(method url-fetch)
@@ -1644,8 +1766,9 @@ module provides support functions to the automatically generated code.")
version ".tar.gz"))
(sha256
(base32
- "1vz9c4v0k8azk2b08swwybrshzw32x8djjpq13mf9v15x1qyjclr"))
- (patches (search-patches "pyqt-configure.patch"))))
+ "00wn9svgyp0fsrkc4ma15zcxg31pw4gsgaz6nwb3fhy3al8miakw"))
+ (patches (search-patches "pyqt-configure.patch"
+ "pyqt-public-sip.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("qtbase" ,qtbase))) ; for qmake
@@ -1672,12 +1795,6 @@ module provides support functions to the automatically generated code.")
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-build-with-qt-5.11
- ;; See: https://bugs.gentoo.org/654742
- (lambda _
- (substitute* "sip/QtTest/qtestmouse.sip"
- (("void waitForEvents\\(\\) /ReleaseGIL/;") ""))
- #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1697,18 +1814,18 @@ module provides support functions to the automatically generated code.")
python-major+minor
"/site-packages"))
(stubs (string-append lib "/PyQt5")))
- (zero? (system* "python" "configure.py"
- "--confirm-license"
- "--bindir" bin
- "--destdir" lib
- "--designer-plugindir" designer
- "--qml-plugindir" qml
- ; Where to install the PEP 484 Type Hints stub
- ; files. Without this the stubs are tried to be
- ; installed into the python package's
- ; site-package directory, which is read-only.
- "--stubsdir" stubs
- "--sipdir" sip))))))))
+ (invoke "python" "configure.py"
+ "--confirm-license"
+ "--bindir" bin
+ "--destdir" lib
+ "--designer-plugindir" designer
+ "--qml-plugindir" qml
+ ; Where to install the PEP 484 Type Hints stub
+ ; files. Without this the stubs are tried to be
+ ; installed into the python package's
+ ; site-package directory, which is read-only.
+ "--stubsdir" stubs
+ "--sipdir" sip)))))))
(home-page "https://www.riverbankcomputing.com/software/pyqt/intro")
(synopsis "Python bindings for Qt")
(description
@@ -1725,11 +1842,12 @@ contain over 620 classes.")
("qtbase" ,qtbase)))
(inputs
`(("python" ,python-2)
+ ("python2-enum34" ,python2-enum34)
,@(alist-delete "python" (package-inputs python-pyqt))))))
-(define-public python-pyqt-4
+(define-public python2-pyqt-4
(package (inherit python-pyqt)
- (name "python-pyqt")
+ (name "python2-pyqt")
(version "4.12")
(source
(origin
@@ -1742,9 +1860,9 @@ contain over 620 classes.")
(base32
"1nw8r88a5g2d550yvklawlvns8gd5slw53yy688kxnsa65aln79w"))))
(native-inputs
- `(("python-sip" ,python-sip)
+ `(("python-sip" ,python2-sip)
("qt" ,qt-4)))
- (inputs `(("python" ,python-wrapper)))
+ (inputs `(("python" ,python-2)))
(arguments
`(#:tests? #f ; no check target
#:modules ((srfi srfi-1)
@@ -1773,19 +1891,10 @@ contain over 620 classes.")
"--sipdir" sip))))))))
(license (list license:gpl2 license:gpl3)))) ; choice of either license
-(define-public python2-pyqt-4
- (package (inherit python-pyqt-4)
- (name "python2-pyqt")
- (native-inputs
- `(("python-sip" ,python2-sip)
- ("qt" ,qt-4)))
- (inputs
- `(("python" ,python-2)))))
-
(define-public qscintilla
(package
(name "qscintilla")
- (version "2.10.3")
+ (version "2.10.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pyqt/QScintilla2/"
@@ -1793,7 +1902,7 @@ contain over 620 classes.")
version ".tar.gz"))
(sha256
(base32
- "1rw1nlwnyzj5pb86cc5kk56qhrvwvrjvjzgrkwh3g7b9wxl7lrfj"))))
+ "06hs6civq13dvzlws0spjb7gwyk6kynpnfwg5plhahnxf7g5h137"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1850,6 +1959,10 @@ indicators, code completion and call tips.")
"Qsci/Makefile")
(("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+")
(assoc-ref outputs "out")))
+ ;; And fix the installed.txt file
+ (substitute* "installed.txt"
+ (("/gnu/store/[^/]+")
+ (assoc-ref outputs "out")))
#t)))))
(inputs
`(("qscintilla" ,qscintilla)