summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ff9a99c672..05037b034e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2733,19 +2733,7 @@ different kinds of sliders, and much more.")
;; libraries and test executables in a
;; reasonable amount of memory.
"-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
- "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")
- #:phases
- (modify-phases %standard-phases
- (replace 'build
- ;; This is a workaround for the build failing with the error:
- ;; ld: error adding symbols: Malformed archive
- ;; Increasing the maximum number of open file descriptors
- ;; makes the build succeed.
- (lambda* (#:key make-flags #:allow-other-keys)
- (let ((cmd (format #f
- "ulimit -n 4096; make ~{~a~^ ~}"
- make-flags)))
- (invoke "sh" "-c" cmd)))))))
+ "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")