summaryrefslogtreecommitdiff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 6330fabcf9..791aa715c8 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -134,9 +134,5 @@ server and embedded PowerPC, and S390 guests.")
;; the store, and another one for exchanges with the host.
(package (inherit qemu)
(name "qemu-with-multiple-smb-shares")
- (inputs `(,@(package-inputs qemu)
- ("patch/smb-shares"
- ,(search-patch "qemu-multiple-smb-shares.patch"))))
- (arguments
- `(#:patches (list (assoc-ref %build-inputs "patch/smb-shares"))
- ,@(package-arguments qemu)))))
+ (source (origin (inherit (package-source qemu))
+ (patches (search-patch "qemu-multiple-smb-shares.patch"))))))