summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ac4e4fc8b7..5eaaa8c252 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6850,7 +6850,15 @@ applications.")
package and greatly reduce the number of imports for your users. It is a small
pure Python module that works on virtually all Python versions.")
(home-page "https://bitbucket.org/hpk42/apipkg")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-apipkg))))))
+
+(define-public python2-apipkg
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-apipkg)))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))))
(define-public python-execnet
(package