summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm57
1 files changed, 39 insertions, 18 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5a32681643..86ff4f2044 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3344,20 +3344,38 @@ color scales, and color space conversion easy. It has support for:
(define-public python-pygit2
(package
(name "python-pygit2")
- (version "0.26.4")
+ (version "0.27.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pygit2" version))
(sha256
(base32
- "145k3fsd21274swia7mcc7n3kzlbd47xmg55mxsjdb5d9b7fr858"))))
+ "046ahvsb7a20sgvscqfm3cb32sp3sii4gim9vz7zzrkf7yz16xlv"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Remove after the next update. See:
+ ;; https://github.com/libgit2/pygit2/pull/851
+ (add-after 'unpack 'compile-with-cffi
+ (lambda _
+ (substitute* "setup.py"
+ (("install_requires")
+ "setup_requires=['cffi'],\n install_requires"))
+ #t))
+ (add-after 'unpack 'fix-dependency-versioning
+ (lambda _
+ (substitute* "setup.py"
+ (("<") "<="))
+ #t)))))
(propagated-inputs
`(("python-six" ,python-six)
("python-cffi" ,python-cffi)
("libgit2" ,libgit2)
("python-tox" ,python-tox)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/libgit2/pygit2")
(synopsis "Python bindings for libgit2")
(description "Pygit2 is a set of Python bindings to the libgit2 shared
@@ -4057,17 +4075,17 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python-pillow
(package
(name "python-pillow")
- (version "5.2.0")
+ (version "5.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "1ary9mj2ddllq3lkxgn6aac7qxqiwbcg2pacrl94py58ql9x9czq"))))
+ "0qrkcjszym7ixffg5zphhp8a07w8w11yyc2ylcbdrhwm771z316m"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)))
(inputs
`(("freetype" ,freetype)
("lcms" ,lcms)
@@ -4079,19 +4097,22 @@ the OleFileIO module from PIL, the Python Image Library.")
(propagated-inputs
`(("python-olefile" ,python-olefile)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after
- 'install 'check-installed
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (begin
- (setenv "HOME" (getcwd))
- ;; Make installed package available for running the
- ;; tests
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "selftest.py" "--installed")
- (invoke "python" "-m" "pytest" "-vv"))))
- (delete 'check))))
- (home-page "https://pypi.python.org/pypi/Pillow")
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-ldconfig
+ (lambda _
+ (substitute* "setup.py"
+ (("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
+ (delete 'check) ; We must run checks after python-pillow is installed.
+ (add-after 'install 'check-installed
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (begin
+ (setenv "HOME" (getcwd))
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv")))))))
+ (home-page "https://python-pillow.org")
(synopsis "Fork of the Python Imaging Library")
(description
"The Python Imaging Library adds image processing capabilities to your