summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm56
1 files changed, 54 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 372f763ee5..b15e5b66d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -21,7 +21,7 @@
(define-module (gnu packages python)
#:use-module ((guix licenses)
- #:select (bsd-3 bsd-style psfl x11 x11-style
+ #:select (bsd-3 bsd-style expat psfl x11 x11-style
gpl2 gpl2+ lgpl2.1+))
#:use-module ((guix licenses) #:select (zlib)
#:renamer (symbol-prefix-proc 'license:))
@@ -293,6 +293,55 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+(define-public python-lockfile
+ (package
+ (name "python-lockfile")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/l/lockfile/"
+ "lockfile-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iwif7i84gwpvrnpv4brshdk8j6l77smvknm8k3bg77mj6f5ini3"))))
+ (build-system python-build-system)
+ (arguments '(#:test-target "check"))
+ (home-page "http://code.google.com/p/pylockfile/")
+ (synopsis "Platform-independent file locking module")
+ (description
+ "The lockfile package exports a LockFile class which provides a simple
+API for locking files.")
+ (license expat)))
+
+(define-public python2-lockfile
+ (package-with-python2 python-lockfile))
+
+(define-public python-mock
+ (package
+ (name "python-mock")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/m/mock/"
+ "mock-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq"))))
+ (build-system python-build-system)
+ (arguments '(#:test-target "check"))
+ (home-page "http://code.google.com/m/mock/")
+ (synopsis "A Python Mocking and Patching Library for Testing")
+ (description
+ "Mock is a library for testing in Python. It allows you to replace parts
+of your system under test with mock objects and make assertions about how they
+have been used.")
+ (license expat)))
+
+(define-public python2-mock
+ (package-with-python2 python-mock))
+
(define-public python-setuptools
(package
@@ -578,7 +627,10 @@ commands.")
version ".tar.gz"))
(sha256
(base32
- "17ni00p08gp5lkxlrrcnvi3x09fmajnlbz4da03qcgl9q21ym4jd"))))
+ "17ni00p08gp5lkxlrrcnvi3x09fmajnlbz4da03qcgl9q21ym4jd"))
+ (patches (map search-patch
+ (list "pybugz-stty.patch"
+ "pybugz-encode-error.patch")))))
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; SyntaxError with Python 3