summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fa4235703b..2b1255c2ec 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
@@ -1130,18 +1130,22 @@ datetime module, available in Python 2.3+.")
(define-public python-parsedatetime
(package
(name "python-parsedatetime")
- (version "2.1")
+ (version "2.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "parsedatetime" version))
(sha256
(base32
- "0bdgyw6y3v7bcxlx0p50s8drxsh5bb5cy2afccqr3j90amvpii8p"))))
+ "1vkrmd398s11h1zn3zaqqsiqhj9lwy1ikcg6irx2lrgjzjg3rjll"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)
- ("python-pyicu" ,python-pyicu)))
+ ("python-pyicu" ,python-pyicu)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (propagated-inputs
+ `(("python-future" ,python-future)))
(home-page "http://github.com/bear/parsedatetime/")
(synopsis
"Parse human-readable date/time text")
@@ -6161,14 +6165,14 @@ so it might be a tiny bit slower.")
(define-public python-waf
(package
(name "python-waf")
- (version "1.9.5")
+ (version "1.9.8")
(source (origin
(method url-fetch)
(uri (string-append "https://waf.io/"
"waf-" version ".tar.bz2"))
(sha256
(base32
- "1sl3ipi2czds57rlzjnpdzqa0skx8asfvmh3qmibpvdwf15rpppg"))))
+ "0wl4cnmp06lfxqjxaan58bqxn27smhydz0sg5prrfbl3bsw4gv6q"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -6182,7 +6186,7 @@ so it might be a tiny bit slower.")
(replace 'install
(lambda _
(copy-file "waf" %output))))))
- (home-page "http://waf.io/")
+ (home-page "https://waf.io/")
(synopsis "Python-based build system")
(description
"Waf is a Python-based framework for configuring, compiling and installing