summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 876ce900a1..a271ad46b7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3837,6 +3837,14 @@ To address this and enable easy cycling over arbitrary @code{kwargs}, the
(build-system python-build-system)
(propagated-inputs
`(("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "nosetests" "--all-modules" "-v" "colorspacious")))))))
(home-page "https://github.com/njsmith/colorspacious")
(synopsis "Python library for colorspace conversions")
(description "@code{colorspacious} is a Python library that lets you