summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 59c460af3b..d64f6331d9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -201,24 +201,24 @@ data types.")
(define-public python
(package (inherit python-2)
- (version "3.3.5")
+ (version "3.4.3")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
- (patches (list (search-patch "python-fix-tests.patch")
- (search-patch "python-sqlite-3.8.4-test-fix.patch")
- (search-patch "python-libffi-mips-n32-fix.patch")))
+ (patches (list (search-patch "python-fix-tests.patch")))
(patch-flags '("-p0"))
(sha256
(base32
- "1rdncc7g8g6f3lfdg33rli1yffbiq8z283xy4f5ksl1l8i49psdb"))))
+ "1f4nm4z08sy0kqwisvv95l02crv6dyysdmx44p1mz3bn6csrdcxm"))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
(list (search-path-specification
(variable "PYTHONPATH")
- (files '("lib/python3.3/site-packages")))))))
+ (files (list (string-append "lib/python"
+ (version-major+minor version)
+ "/site-packages"))))))))
(define-public python-wrapper
(package (inherit python)