summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fc8582f2f4..f444cdbb64 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2241,10 +2241,12 @@ version numbers.")
(synopsis "Implementation of JSON Schema for Python")
(description
"Jsonschema is an implementation of JSON Schema for Python.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-jsonschema))))))
(define-public python2-jsonschema
- (let ((jsonschema (package-with-python2 python-jsonschema)))
+ (let ((jsonschema (package-with-python2
+ (strip-python2-variant python-jsonschema))))
(package (inherit jsonschema)
(inputs
`(("python2-functools32" ,python2-functools32)