summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d110a1cb32..ba9153b68b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -342,8 +342,11 @@ data types.")
(base32
"1c6v1n9nz4mlx9mw1125fxpmbrgniqdbbx9hnqx44maqazb2mzpf"))
(snippet
- '(delete-file
- "Lib/ctypes/test/test_win32.py")))) ; fails on aarch64
+ '(begin
+ (for-each delete-file
+ '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
+ "Lib/test/test_fcntl.py"))
+ #t))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
@@ -1874,7 +1877,9 @@ code introspection, and logging.")
(propagated-inputs
`(("python-py" ,python-py)))
(native-inputs
- `(("python-nose" ,python-nose)
+ `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
+ ("bash" ,bash)
+ ("python-nose" ,python-nose)
("python-mock" ,python-mock)))
(home-page "http://pytest.org")
(synopsis "Python testing library")
@@ -1911,9 +1916,8 @@ and many external plugins.")
line)))
#t)))))
(native-inputs
- `(("python-nose" ,python-nose)
- ("python-mock" ,python-mock)
- ("python-hypothesis" ,python-hypothesis)))
+ `(("python-hypothesis" ,python-hypothesis)
+ ,@(package-native-inputs python-pytest)))
(properties `((python2-variant . ,(delay python2-pytest-3.0))))))
(define-public python2-pytest-3.0
@@ -7636,10 +7640,6 @@ Python's @code{ctypes} foreign function interface (FFI).")
(package
(inherit file)
(name "python-file")
- (source (origin
- (inherit (package-source file))
- ;; This patch should not be applied to python2-file.
- (patches (search-patches "python-file-double-encoding-bug.patch"))))
(build-system python-build-system)
(arguments
'(#:tests? #f ;no tests