summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 505e4a813b..911cf2dc12 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -925,6 +925,24 @@ have been used.")
(define-public python2-mock
(package-with-python2 python-mock))
+;;; Some packages (notably, certbot and python-acme) rely on this newer version
+;;; of python-mock. However, a large number of packages fail to build with
+;;; mock@2, so we add a new variable for now. Also, there may be a dependency
+;;; cycle between mock and six, so we avoid creating python2-mock@2 for now.
+(define-public python-mock-2
+ (package
+ (inherit python-mock)
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mock" version))
+ (sha256
+ (base32
+ "1flbpksir5sqrvq2z0dp8sl4bzbadg21sj4d42w3klpdfvgvcn5i"))))
+ (propagated-inputs
+ `(("python-pbr" ,python-pbr-minimal)
+ ,@(package-propagated-inputs python-mock)))))
(define-public python-setuptools
(package
@@ -15382,3 +15400,26 @@ many of the popular cloud service providers using a unified API.")
(define-public python2-apache-libcloud
(package-with-python2 python-apache-libcloud))
+
+(define-public python-smmap2
+ (package
+ (name "python-smmap2")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smmap2" version))
+ (sha256
+ (base32
+ "1hvn28p3zvxa98sbi9lrqvv2ps4q284j4jq9a619zw0m7yv0sly7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nosexcover" ,python-nosexcover)))
+ (home-page "https://github.com/Byron/smmap")
+ (synopsis "Python sliding window memory map manager")
+ (description "@code{smmap2} is a pure Python implementation of a sliding
+window memory map manager.")
+ (license license:bsd-3)))
+
+(define-public python2-smmap2
+ (package-with-python2 python-smmap2))