summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index df98778c0f..a057e2a6a3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -342,9 +342,15 @@ data types.")
(snippet
'(begin
(for-each delete-file
- '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
- "Lib/test/test_fcntl.py" ; fails on aarch64
- "Lib/test/test_posix.py")) ; fails on aarch64
+ '(;; This test may hang and eventually run out of
+ ;; memory on some systems:
+ ;; <https://bugs.python.org/issue34587>
+ "Lib/test/test_socket.py"
+
+ ;; These tests fail on AArch64.
+ "Lib/ctypes/test/test_win32.py"
+ "Lib/test/test_fcntl.py"
+ "Lib/test/test_posix.py"))
#t))))
(arguments
(substitute-keyword-arguments (package-arguments python-2)